;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages key-mon) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (gnu packages) #:use-module (gnu packages python) #:use-module (gnu packages python-xyz) #:use-module (gnu packages gtk) #:use-module (gnu packages gnome) #:use-module (guix build-system python)) (define-public key-mon (package (name "key-mon") (version "1.17") (source (origin (method url-fetch) (uri (string-append "http://key-mon.googlecode.com/files/key-mon-" version ".tar.gz")) (sha256 (base32 "1liz0dxcqmchbnl1xhlxkqm3gh76wz9jxdxn9pa7dy77fnrjkl5q")))) (build-system python-build-system) (arguments `(#:python ,python-2 ;uses the Python 2 'print' syntax #:tests? #f)) ;no tests (inputs `(("python2-xlib" ,python2-xlib) ("python2-pygtk" ,python2-pygtk) ("python2-rsvg" ,python2-rsvg))) (home-page "https://code.google.com/p/key-mon") (synopsis "Show keyboard and mouse status") (description "The key-mon utility displays the current keyboard and mouse status. This is useful for teaching and screencasts.") (license asl2.0))) fb336'>root/gnu/packages/tor.scm
AgeCommit message (Expand)Author
2019-10-15gnu: onionshare: Update to 2.2....Eric Bavier
2019-09-19gnu: tor: Update to 0.4.1.6....Tobias Geerinckx-Rice
2019-08-20gnu: tor: Update to 0.4.1.5....Tobias Geerinckx-Rice
2019-08-13gnu: onionshare: Upgrade to 2.1....Eric Bavier
2019-07-22gnu: zstd: Move libraries to separate outputs....Marius Bakke
2019-05-05gnu: tor: Remove explicit hardening flags....Tobias Geerinckx-Rice
2019-05-03gnu: tor: Update to 0.4.0.5....Tobias Geerinckx-Rice
2019-03-18Correct name and email address for ng0....ng0
2019-02-21gnu: tor: Update to 0.3.4.11 [fixes TROVE-2019-001]....Tobias Geerinckx-Rice
2019-02-18gnu: onionshare: Update to 1.3.2....Tobias Geerinckx-Rice
2019-02-08gnu: torsocks: Update to 2.3.0....Tobias Geerinckx-Rice
2019-02-08gnu: torsocks: Don't use NAME in source URI....Tobias Geerinckx-Rice
2019-02-05gnu: nyx: Update to 2.1.0....Tobias Geerinckx-Rice