;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see .
(define-module (gnu packages jrnl)
#:use-module (guix packages)
#:use-module (guix licenses)
#:use-module (guix download)
#:use-module (guix build-system python)
#:use-module (gnu packages check)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages time))
(define-public jrnl
(package
(name "jrnl")
(version "1.9.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/maebert/jrnl/archive/"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
(build-system python-build-system)
(native-inputs
`(("behave" ,behave)))
(inputs
`(("python" ,python)
("python-keyring" ,python-keyring)
("python-pycrypto" ,python-pycrypto)
("python-pytz" ,python-pytz)
("python-tzlocal" ,python-tzlocal)
("python-six" ,python-six)
("python-dateutil" ,python-dateutil)
("python-parsedatetime" ,python-parsedatetime)))
(home-page "http://maebert.github.io/jrnl/")
(synopsis "Personal journal application")
(description
"Jrnl is a command line journal application that stores your journal in a
plain text file. Optionally, your journal can be encrypted using 256-bit AES
encryption.")
(license x11)))
-locals.el?id=687ef47768d12d36dd3718be564433fbb5309b0d&showmsg=1'>Expand)Author |
2020-12-15 | system: 'init' does not recompute the hash of each store item.... | Ludovic Courtès |
2020-11-17 | Merge remote-tracking branch 'origin/version-1.2.0' into master... | Maxim Cournoyer |
2020-11-16 | .dir-locals.el: Add upstream report link.... | Miguel Ángel Arruga Vivas |
2020-11-16 | .dir-locals.el: Use setq-local on guix-directory.... | Christopher Lemmer Webber |
2020-11-16 | .dir-locals.el: Prevent errors if .dir-locals.el isn't found.... | Christopher Lemmer Webber |
2020-11-12 | maint: update-guix-package: Optionally add sources to store.... | Maxim Cournoyer |
2020-11-01 | .dir-locals.el: Require cl-lib at runtime.... | Miguel Ángel Arruga Vivas |
2020-10-31 | .dir-locals.el: Automatically set the GEISER-GUILE-LOAD-PATH variable.... | Maxim Cournoyer |
2020-10-19 | maint: update-guix-package: Prevent accidentally breaking guix pull.... | Maxim Cournoyer |
2020-09-14 | deduplication: pass store directory to replace-with-link.... | Caleb Ristvedt |
2020-09-14 | .dir-locals.el: fix call-with-{retrying-}transaction indenting.... | Caleb Ristvedt |
2020-08-26 | .dir-locals.el: Add indentation rule for 'package/inherit'.... | Ludovic Courtès |