;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see .
(define-module (gnu packages jrnl)
#:use-module (guix packages)
#:use-module (guix licenses)
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages check)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time))
(define-public jrnl
(package
(name "jrnl")
(version "1.9.7")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/maebert/jrnl")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "1bjjyfc3fnsy0h299s3jj42wnigj43xdyp5ppi1cvkqbwl369935"))))
(build-system python-build-system)
(native-inputs
`(("behave" ,behave)))
(inputs
`(("python" ,python)
("python-keyring" ,python-keyring)
("python-pycrypto" ,python-pycrypto)
("python-pytz" ,python-pytz)
("python-tzlocal" ,python-tzlocal)
("python-six" ,python-six)
("python-dateutil" ,python-dateutil)
("python-parsedatetime" ,python-parsedatetime)))
(home-page "https://maebert.github.io/jrnl/")
(synopsis "Personal journal application")
(description
"Jrnl is a command line journal application that stores your journal in a
plain text file. Optionally, your journal can be encrypted using 256-bit AES
encryption.")
(license x11)))
ss='nohover'>Age | Commit message (Expand) | Author |
2023-05-31 | nls: Update translations....* doc/guix-cookbook.texi (Top): Mention Slovak.
| Florian Pelz |
2023-03-07 | nls: Update translations. | Julien Lepiller |
2023-01-05 | nls: Update translations....* po/guix/ka.po: New file.
* po/guix/LINGUAS: Add it.
* po/packages/uk.po: New file.
* po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-12-04 | nls: Update translations....po/packages/vi.po: New file.
po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-11-04 | nls: Update translations....* po/guix/lt.po: New file.
* po/guix/LINGUAS: Add lt.
| Julien Lepiller |
2022-10-06 | nls: Update translations. | Julien Lepiller |
2022-09-04 | nls: Update translations. | Julien Lepiller |
2022-08-10 | nls: Update translations....po/guix/bn.po: New file.
po/guix/LINGUAS: Add it.
| Julien Lepiller |
2022-07-09 | nls: Update translations....po/guix/tr.po: New file.
po/guix/LINGUAS: Add it.
| Julien Lepiller |
2022-06-04 | nls: Update translations....po/packages/tr.po: New file.
po/packages/LINGUAS: Add it.
| Julien Lepiller |
2022-05-01 | nls: Update translations....po/guix/ja.po: New file.
po/guix/LINGUAS: Add it.
| Julien Lepiller |
2022-04-02 | nls: Update translations....* po/packages/fi.po: New file.
* po/packages/LINGUAS: Add it.
| Julien Lepiller |