;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier
;;; Copyright © 2015 Mark H Weaver
;;; Copyright © 2016 Efraim Flashner
;;; Copyright © 2019 Tobias Geerinckx-Rice
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see .
(define-module (gnu packages jrnl)
#:use-module (guix packages)
#:use-module (guix licenses)
#:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (gnu packages check)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time))
(define-public jrnl
(package
(name "jrnl")
(version "1.9.7")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/maebert/jrnl")
(commit version)))
(file-name (git-file-name name version))
(sha256
(base32 "1bjjyfc3fnsy0h299s3jj42wnigj43xdyp5ppi1cvkqbwl369935"))))
(build-system python-build-system)
(native-inputs
`(("behave" ,behave)))
(inputs
`(("python" ,python)
("python-keyring" ,python-keyring)
("python-pycrypto" ,python-pycrypto)
("python-pytz" ,python-pytz)
("python-tzlocal" ,python-tzlocal)
("python-six" ,python-six)
("python-dateutil" ,python-dateutil)
("python-parsedatetime" ,python-parsedatetime)))
(home-page "https://maebert.github.io/jrnl/")
(synopsis "Personal journal application")
(description
"Jrnl is a command line journal application that stores your journal in a
plain text file. Optionally, your journal can be encrypted using 256-bit AES
encryption.")
(license x11)))
Age | Commit message (Expand) | Author |
2020-04-02 | gnu: cedille: Install the info pages....* gnu/packages/cedille.scm (cedille)[arguments]: Rename phase
'patch-cedille-path-el' to 'patch-cedille-paths' and add substitution for the
info page location. In the 'copy-cedille-mode' phase, install the info page.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| John Soo |
2020-04-02 | gnu: cedille: Fix emacs outputs....* gnu/packages/cedille.scm (cedille):[arguments] Add slashes to output paths.
Signed-off-by: Marius Bakke <mbakke@fastmail.com>
| John Soo |
2020-03-19 | gnu: cedille: Remove guix.d from the Elisp installation directory....* gnu/packages/cedille.scm (cedille)[phases]{patch-cedille-path-el}: Update
the Elisp installation prefix used.
{copy-cedille-mode}: Likewise.
| Maxim Cournoyer |
2020-02-23 | gnu: cedille: Update to 1.1.2....* gnu/packages/cedille.scm (cedille): Update to 1.1.2.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| John Soo |