;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Eric Bavier ;;; Copyright © 2015 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages jrnl) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system python) #:use-module (gnu packages python)) (define-public jrnl (package (name "jrnl") (version "1.8.4") (source (origin (method url-fetch) (uri (string-append "https://github.com/maebert/jrnl/archive/" version ".tar.gz")) (file-name (string-append name "-" version ".tar.gz")) (sha256 (base32 "019ky09sj5i7frmca0imv4jm46mn3f4lzah2wmiwxh22cisj7ksn")))) (build-system python-build-system) (native-inputs `(("python-setuptools" ,python-setuptools) ("behave" ,behave))) (inputs `(("python" ,python) ("python-keyring" ,python-keyring) ("python-pycrypto" ,python-pycrypto) ("python-pytz" ,python-pytz) ("python-tzlocal" ,python-tzlocal) ("python-six" ,python-six) ("python-dateutil" , python-dateutil-2) ("python-parsedatetime" ,python-parsedatetime))) (home-page "http://maebert.github.io/jrnl/") (synopsis "Personal journal application") (description "Jrnl is a command line journal application that stores your journal in a plain text file. Optionally, your journal can be encrypted using 256-bit AES encryption.") (license x11))) d100e27609'>gnu/packages/cluster.scm
AgeCommit message (Expand)Author
2020-11-30gnu: drbd-utils: Update to 9.15.1....Tobias Geerinckx-Rice
2020-10-10gnu: drbd-utils: Update to 9.15.0....Marius Bakke
2020-07-02gnu: Add drbd-utils....Marius Bakke
2020-01-08gnu: keepalived: Update to 2.0.19....Oleg Pykhalov
2019-12-11gnu: libraft: Update to 0.9.11....Andrew Miloradovsky
2019-09-24gnu: keepalived: Update home page....Marius Bakke
2019-09-24gnu: keepalived: Update to 2.0.18....Marius Bakke
2019-09-24gnu: keepalived: Fix documentation generation....Marius Bakke
2019-09-08gnu: libraft: Fetch source from Git....Ludovic Courtès
2019-09-08gnu: Add libraft...Andrew Miloradovsky
2019-05-24gnu: Move Sphinx and friends to (gnu packages sphinx)....Marius Bakke
2019-01-15gnu: Separate Python core packages from the rest....Ricardo Wurmus
2018-07-05gnu: keepalived: Update to 2.0.5....Tobias Geerinckx-Rice
2018-06-29gnu: keepalived: Edit synopsis & description....Tobias Geerinckx-Rice
2018-06-29gnu: keepalived: Update to 2.0.4....Tobias Geerinckx-Rice