;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see .
(define-module (gnu packages jrnl)
#:use-module (guix packages)
#:use-module (guix licenses)
#:use-module (guix download)
#:use-module (guix build-system python)
#:use-module (gnu packages check)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages time))
(define-public jrnl
(package
(name "jrnl")
(version "1.9.7")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/maebert/jrnl/archive/"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0mfq7hhw5np2dj9jlxpyyk2cg9i0xgz2brb894d928hczszy97bq"))))
(build-system python-build-system)
(native-inputs
`(("behave" ,behave)))
(inputs
`(("python" ,python)
("python-keyring" ,python-keyring)
("python-pycrypto" ,python-pycrypto)
("python-pytz" ,python-pytz)
("python-tzlocal" ,python-tzlocal)
("python-six" ,python-six)
("python-dateutil" ,python-dateutil)
("python-parsedatetime" ,python-parsedatetime)))
(home-page "http://maebert.github.io/jrnl/")
(synopsis "Personal journal application")
(description
"Jrnl is a command line journal application that stores your journal in a
plain text file. Optionally, your journal can be encrypted using 256-bit AES
encryption.")
(license x11)))
tr>2021-05-20 | The #guix channel is hosted by Libera Chat.... | Tobias Geerinckx-Rice |
2020-10-23 | doc: Update README.... | Maxim Cournoyer |
2020-10-22 | README: Refer to the manual for building from Git.... | Maxim Cournoyer |
2020-06-02 | doc: Update README to refer to the manual.... | Ludovic Courtès |
2019-11-09 | doc: Mention value /var to localstatedir option.... | zimoun |
2019-09-04 | doc: Update 'README'.... | Ludovic Courtès |
2019-01-09 | build: Require Guile 2.2.... | Ludovic Courtès |
2018-12-02 | Make Guile-JSON a required dependency.... | Eric Bavier |
2018-11-23 | Update Guile-SQLite3 URL everywhere.... | Ludovic Courtès |
2018-09-04 | Switch to Guile-Gcrypt.... | Ludovic Courtès |
2018-06-27 | doc: Specify Guile-SQLite3 minimum version.... | Ludovic Courtès |
2018-06-14 | build: Require Guile-SQLite3.... | Ludovic Courtès |
2018-02-26 | build: Require Guile >= 2.0.13.... | Ludovic Courtès |
2018-01-07 | doc: Mark zlib as mandatory, libbz2 as optional.... | Ludovic Courtès |
2018-01-01 | doc: Update requirements in 'README'.... | Mathieu Lirzin |
2017-09-25 | README: Replace http:// with https:// where applicable. | Marius Bakke |