;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2018 Manolis Fragkiskos Ragkousis ;;; Copyright © 2021 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages jose) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix utils) #:use-module (guix build-system meson) #:use-module (gnu packages pkg-config) #:use-module (gnu packages web) #:use-module (gnu packages compression) #:use-module (gnu packages tls)) (define-public jose (package (name "jose") (version "11") (source (origin (method url-fetch) (uri (string-append "https://github.com/latchset/jose/releases/" "download/v" version "/jose-" version ".tar.xz")) (sha256 (base32 "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2")))) (build-system meson-build-system) (native-inputs (list pkg-config)) (inputs (list jansson zlib openssl)) (home-page "https://github.com/latchset/jose") (synopsis "Object Signing and Encryption") (description "C-language implementation of Javascript Object Signing and Encryption") (license license:asl2.0))) form>
AgeCommit message (Expand)Author
2020-04-21tests: ssh: Explicitly wait for port 22....Ludovic Courtès
2019-05-09services: Log-in services now require "pam_loginuid"....Ludovic Courtès
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-06-13tests: Honor the return value of 'start-service'....Clément Lassieur
2018-06-01tests: ssh: Use 'with-extensions'....Ludovic Courtès
2017-11-01tests: ssh: Make sure we can run executables from PATH....Marius Bakke
2017-07-23Merge branch 'master' into core-updatesLeo Famulari
2017-07-20tests: Use 'virtual-machine' records instead of monadic procedures....Ludovic Courtès
2017-07-18tests: ssh: Use 'guile-ssh'....Ludovic Courtès
2017-06-12marionette: Factorize 'wait-for-file'....Ludovic Courtès
2017-05-21tests: ssh: Use 'guile2.0-ssh'....Ludovic Courtès
2017-04-01tests: Introduce 'simple-operating-system' and use it....Ludovic Courtès
2017-03-21tests: ssh: Add a test for SFTP....Clément Lassieur
2017-03-21tests: ssh: Abstract session connection and authentication....Clément Lassieur