;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2018 Manolis Fragkiskos Ragkousis ;;; Copyright © 2021 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages jose) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix utils) #:use-module (guix build-system meson) #:use-module (gnu packages pkg-config) #:use-module (gnu packages web) #:use-module (gnu packages compression) #:use-module (gnu packages tls)) (define-public jose (package (name "jose") (version "11") (source (origin (method url-fetch) (uri (string-append "https://github.com/latchset/jose/releases/" "download/v" version "/jose-" version ".tar.xz")) (sha256 (base32 "09c2kn9cjqkgx4g0rf6c2k3ng9970r468c9z7067j8kyf7ksywp2")))) (build-system meson-build-system) (native-inputs (list pkg-config)) (inputs (list jansson zlib openssl)) (home-page "https://github.com/latchset/jose") (synopsis "Object Signing and Encryption") (description "C-language implementation of Javascript Object Signing and Encryption") (license license:asl2.0))) edb928c'>root/m4
AgeCommit message (Expand)Author
2022-01-14gnu: bootstrap: Add support for riscv64-linux....Efraim Flashner
2021-12-14build: Adjust 'courage level' of different systems....Efraim Flashner
2021-05-23gnu: bootstrap: Add support for powerpc-linux....Efraim Flashner
2021-03-23Add powerpc64le-linux as a supported Guix architecture....Chris Marusich
2021-03-17maint: Check whether Guile-zlib is recent enough....Ludovic Courtès
2021-02-04build: Add '--with-channel-commit' and related configure flags....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-09-08Remove (guix json) and require Guile-JSON 4.3.0+....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-07-20ssh: Speed up RPCs by using #:nodelay....Lars-Dominik Braun
2020-05-28doc: Remove explicit support for mips64el-linux....Efraim Flashner
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-02-22build: Depend on guile-ssh 0.12.0...Lars-Dominik Braun
2019-08-17build: 'GUIX_CHECK_GUILE_JSON' really checks for Guile-JSON 3.x....Ludovic Courtès
2019-07-25maint: Switch to Guile-JSON 3.x....Ludovic Courtès
2019-05-06Add (guix lzlib)....Pierre Neidhardt