;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages indent) #:use-module (gnu packages) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public indent (package (name "indent") (version "2.2.10") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/indent/indent-" version ".tar.gz")) (sha256 (base32 "0f9655vqdvfwbxvs1gpa7py8k1z71aqh8hp73f65vazwbfz436wa")))) (build-system gnu-build-system) (arguments `(#:phases (alist-cons-after 'unpack 'fix-docdir (lambda _ ;; Although indent uses a modern autoconf in which docdir ;; defaults to PREFIX/share/doc, the doc/Makefile.am ;; overrides this to be in PREFIX/doc. Fix this. (substitute* "doc/Makefile.in" (("^docdir = .*$") "docdir = @docdir@\n"))) %standard-phases))) (synopsis "Code reformatter") (description "Indent is a program that makes source code easier to read by reformatting it in a consistent style. It can change the style to one of several different styles such as GNU, BSD or K&R. It has some flexibility to deal with incomplete or malformed syntax. GNU indent offers several extensions over the standard utility.") (license license:gpl3+) (home-page "http://www.gnu.org/software/indent/"))) '>
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-24 00:23:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-24 01:28:18 +0200
commit5b76cdae9dfae44318a56d6b442cc91abd719882 (patch)
tree9f52391d601318d1116555ed60dfd5da6ce653da /gnu/packages
parent169cbd808aa712a355173609fe309ef1b83140fa (diff)
downloadguix-5b76cdae9dfae44318a56d6b442cc91abd719882.tar.gz
guix-5b76cdae9dfae44318a56d6b442cc91abd719882.zip
gnu: qutebrowser: Update to 2.2.2.
* gnu/packages/web-browsers.scm (qutebrowser): Update to 2.2.2.
Diffstat (limited to 'gnu/packages')