;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages idutils) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (guix licenses) #:use-module (gnu packages emacs) #:use-module (gnu packages)) (define-public idutils (package (name "idutils") (version "4.6") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/idutils/idutils-" version ".tar.xz")) (sha256 (base32 "1hmai3422iaqnp34kkzxdnywl7n7pvlxp11vrw66ybxn9wxg90c1")) (patches (list (search-patch "diffutils-gets-undeclared.patch"))))) (build-system gnu-build-system) (native-inputs `(("emacs" ,emacs-no-x))) (home-page "http://www.gnu.org/software/idutils/") (synopsis "Identifier database utilities") (description "The GNU idutils package includes tools to create an index of textual tokens used in a list of file names and then to query that index. Thus, it allows the user to, for example, find all the uses of a particular function in a large programming project. In addition to handling textual tokens, it can also handle numeric constants and the contents of character strings.") (license gpl3+))) d colspan='2'/>context:space:mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-24 23:30:42 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-12-07 14:04:13 -0500
commit20db7a3d4c039c49e14616f55a0136b8180058c3 (patch)
treef568bf418bac67ad32b8ec0a00e602fccdca4005
parent7dee3942fc8013b7d0663015a727ec557178a238 (diff)
downloadguix-20db7a3d4c039c49e14616f55a0136b8180058c3.tar.gz
guix-20db7a3d4c039c49e14616f55a0136b8180058c3.zip
gnu: devhelp: Update to 3.32.0.
* gnu/packages/gnome.scm (devhelp): Update to 3.32.0. [arguments]: Set glib-or-gtk? flag.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm