;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Jakob L. Kreuze <zerodaysfordays@sdf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages i2p)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages check)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages tls)
  #:use-module (gnu packages upnp)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (guix build-system cmake)
  #:use-module ((guix licenses) #:prefix license:))

(define-public i2pd
  (package
    (name "i2pd")
    (version "2.50.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/PurpleI2P/i2pd")
             (commit version)))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1vr251mgffawi3rj51dzlnv3fs1ssz6gl17qbsyhfr5fcd7s0hc5"))))
    (build-system cmake-build-system)
    (native-inputs (list check pkg-config))
    (inputs
     (list boost miniupnpc openssl zlib))
    (arguments
     (list
      #:configure-flags
      #~(list (string-append "-S" #$source "/build")
              "-DWITH_UPNP=ON"
              "-DBUILD_SHARED_LIBS=ON"
              "-DBUILD_TESTING=ON")))
    (home-page "https://i2pd.website/")
    (synopsis "Router for an end-to-end encrypted and anonymous internet")
    (description "i2pd is a client for the anonymous I2P network, upon which
applications for file sharing, web browsing, instant messaging, and more are
built. i2pd allows people from all around the world to communicate and share
information securely without restrictions.")
    (license license:bsd-3)))
'>2019-03-26</span></td><td><a href='/guix/commit/etc/snippets?id=6994e6743603ab73cc32d32786a55672f4fa46f0'>etc: Add "rename" snippet.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/text-mode/guix-commit-message-rename-package: New file.
</span></span></td><td>Pierre Neidhardt</td></tr>
<tr><td><span title='2019-03-08 00:17:30 +0100'>2019-03-08</span></td><td><a href='/guix/commit/etc/snippets?id=95803946c7dbdff88db09fa5fe98e70d607712a7'>etc: snippets: Prefill package name.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/text-mode/guix-commit-message-add-package: Extract package
name from diff.
</span></span></td><td>Ricardo Wurmus</td></tr>
<tr><td><span title='2019-03-07 23:55:24 +0100'>2019-03-07</span></td><td><a href='/guix/commit/etc/snippets?id=d6234620ace1863d8102b065311ef3d94e0931da'>etc: snippets: Prefill package name and version.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/text-mode/guix-commit-message-update-package: Extract package
name and version from git diff output.
</span></span></td><td>Ricardo Wurmus</td></tr>
<tr><td><span title='2018-10-10 17:33:42 +0200'>2018-10-10</span></td><td><a href='/guix/commit/etc/snippets?id=d634db9401ac320383d45e24431442259cf6a2a4'>etc: Use git-file-name if origin is git-fetch.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/scheme-mode/guix-origin: Use git-file-name.
</span></span></td><td>Pierre Neidhardt</td></tr>
<tr><td><span title='2018-07-13 12:45:11 +0530'>2018-07-13</span></td><td><a href='/guix/commit/etc/snippets?id=9286c2950494b110e12d58d4ebd693d614120afe'>etc: snippets: Add guix-commit-message-use-https-home-page.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/text-mode/guix-commit-message-use-https-home-page: New file.
* doc/contributing.texi (The Perfect Setup): Document new snippet.
</span></span></td><td>Arun Isaac</td></tr>
<tr><td><span title='2018-07-13 09:27:31 +0530'>2018-07-13</span></td><td><a href='/guix/commit/etc/snippets?id=202befb4ae775cfdab1566f4a69ec184406a56be'>etc: snippets: Add new build systems to package snippet.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/scheme-mode/guix-package: Add android-ndk-build-system and
scons-build-system as possibilities for the build-system field.
</span></span></td><td>Arun Isaac</td></tr>
<tr><td><span title='2017-12-15 23:15:32 +0100'>2017-12-15</span></td><td><a href='/guix/commit/etc/snippets?id=42cdcdff1945b112452029c6a79445aac15ffd16'>etc: Add snippets.</a><span class='msg-avail'>...<span class='msg-tooltip'>* etc/snippets/scheme-mode/guix-cvs-reference,
etc/snippets/scheme-mode/guix-git-reference,
etc/snippets/scheme-mode/guix-hg-reference,
etc/snippets/scheme-mode/guix-origin,
etc/snippets/scheme-mode/guix-package,
etc/snippets/scheme-mode/guix-svn-reference,
etc/snippets/text-mode/guix-commit-message-add-package,
etc/snippets/text-mode/guix-commit-message-update-package: New files.
* doc/contributing.texi (The Perfect Setup): Document snippets.
</span></span></td><td>Ricardo Wurmus</td></tr>