;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Paul van der Walt ;;; Copyright © 2015 Eric Bavier ;;; Copyright © 2015 Federico Beffa ;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus ;;; Copyright © 2016 Nikita ;;; Copyright © 2016 David Craven ;;; Copyright © 2017 Danny Milosavljevic ;;; Copyright © 2017 rsiddharth ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice ;;; Copyright © 2018 Tonton ;;; Copyright © 2018 Arun Isaac ;;; Copyright © 2019 Timothy Sample ;;; Copyright © 2020 John Soo ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages haskell-check) #:use-module (gnu packages) #:use-module (gnu packages haskell-crypto) #:use-module (gnu packages haskell-xyz) #:use-module (guix build-system haskell) #:use-module (guix download) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix utils)) (define-public ghc-tasty-ant-xml (package (name "ghc-tasty-ant-xml") (version "1.1.
#                                               -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.

AC_PREREQ([2.69])
AC_INIT([GNU Guix],
  [m4_esyscmd([build-aux/git-version-gen .tarball-version])],
  [bug-guix@gnu.org], [guix],
  [https://www.gnu.org/software/guix/])
AC_CONFIG_AUX_DIR([build-aux])

AM_INIT_AUTOMAKE([1.14 gnu tar-ustar silent-rules subdir-objects \
 color-tests parallel-tests -Woverride -Wno-portability])

# Enable silent rules by default.
AM_SILENT_RULES([yes])

AC_CONFIG_SRCDIR([guix.scm])
AC_CONFIG_MACRO_DIR([m4])

dnl For the C++ code.  This must be used early.
AC_USE_SYSTEM_EXTENSIONS

AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.19.1])

GUIX_SYSTEM_TYPE
GUIX_ASSERT_SUPPORTED_SYSTEM
GUIX_CHANNEL_METADATA

AM_CONDITIONAL([CROSS_COMPILING], [test "x$cross_compiling" = "xyes"])

AC_ARG_WITH(store-dir,
  AS_HELP_STRING([--with-store-dir=PATH],
    [file name of the store (defaults to /gnu/store)]),
  [storedir="$withval"],
  [storedir="/gnu/store"])
AC_SUBST(storedir)

AC_ARG_WITH([bash-completion-dir],
  AS_HELP_STRING([--with-bash-completion-dir=DIR],
    [name of the Bash completion directory]),
  [bashcompletiondir="$withval"],
  [bashcompletiondir='${sysconfdir}/bash_completion.d'])
AC_SUBST([bashcompletiondir])

AC_ARG_WITH([zsh-completion-dir],
  AS_HELP_STRING([--with-zsh-completion-dir=DIR],
    [name of the Zsh completion directory]),
  [zshcompletiondir="$withval"],
  [zshcompletiondir='${datadir}/zsh/site-functions'])
AC_SUBST([zshcompletiondir])

AC_ARG_WITH([fish-completion-dir],
  AS_HELP_STRING([--with-fish-completion-dir=DIR],
    [name of the Fish completion directory]),
  [fishcompletiondir="$withval"],
  [fishcompletiondir='${datadir}/fish/vendor_completions.d'])
AC_SUBST([fishcompletiondir])

AC_ARG_WITH([selinux-policy-dir],
  AS_HELP_STRING([--with-selinux-policy-dir=DIR],
    [name of the SELinux policy directory]),
  [selinux_policydir="$withval"],
  [selinux_policydir='${datadir}/selinux/'])
AC_SUBST([selinux_policydir])

dnl Better be verbose.
AC_MSG_CHECKING([for the store directory])
AC_MSG_RESULT([$storedir])

AC_ARG_ENABLE([daemon],
  [AS_HELP_STRING([--disable-daemon], [do not build the Nix daemon (C++)])],
  [guix_build_daemon="$enableval"],
  [guix_build_daemon="yes"])

dnl Prepare a version of $localstatedir & co. that does not contain references
dnl to shell variables.  Also set some sane default directory variables for
dnl use with the Guix.  This also causes localstatedir to be /var and
dnl sysconfdir to be /etc.
test "$prefix" = NONE && prefix=
guix_localstatedir="`eval echo $localstatedir | sed -e "s|NONE|$guix_prefix|g"`"
guix_sysconfdir="`eval echo $sysconfdir | sed -e "s|NONE|$guix_prefix|g"`"
guix_sbindir="`eval echo $sbindir | sed -e "s|NONE|$guix_prefix|g"`"
AC_SUBST([guix_localstatedir])
AC_SUBST([guix_sysconfdir])
AC_SUBST([guix_sbindir])

GUIX_CHECK_FILE_NAME_LIMITS([can_run_tests])
AM_CONDITIONAL([CAN_RUN_TESTS], [test "x$can_run_tests" = "xyes"])

dnl We require pkg.m4 (from pkg-config) and guile.m4 (from Guile.)
dnl Make sure they are available.
m4_pattern_forbid([PKG_CHECK_MODULES])
m4_pattern_forbid([GUILE_MODULE_AVAILABLE])
m4_pattern_forbid([^GUILE_P])
m4_pattern_allow([^GUILE_PKG_ERRORS])
m4_pattern_forbid([^GUIX_])

dnl Search for 'guile' and 'guild'.  This macro defines
dnl 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([3.0])
GUILE_PROGS
if test "x$GUILD" = "x"; then
   AC_MSG_ERROR(['guild' binary not found; please check your Guile installation.])
fi

dnl (guix ui), notably, requires 'default-optimization-level' added in 3.0.3.
PKG_CHECK_MODULES([GUILE], [guile-3.0 >= 3.0.3])

dnl Get CFLAGS and LDFLAGS for libguile.
GUILE_FLAGS

dnl Installation directories for .scm and .go files.
guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
guileobjectdir="${libdir}/guile/$GUILE_EFFECTIVE_VERSION/site-ccache"
AC_SUBST([guilemoduledir])
AC_SUBST([guileobjectdir])

dnl The GnuTLS bindings are necessary for substitutes over HTTPS and for 'guix
dnl pull', among other things.
GUILE_MODULE_AVAILABLE([have_gnutls], [(gnutls)])
if test "x$have_gnutls" != "xyes"; then
  AC_MSG_ERROR([The Guile bindings of GnuTLS are missing; please install them.])
fi

dnl Check for Guile-Git.
GUILE_MODULE_AVAILABLE([have_guile_git], [(git)])
if test "x$have_guile_git" != "xyes"; then
  AC_MSG_ERROR([Guile-Git is missing; please install it.])
fi

dnl Check for Guile-JSON.
GUIX_CHECK_GUILE_JSON
if test "x$guix_cv_have_recent_guile_json" != "xyes"; then
  AC_MSG_ERROR([Guile-JSON is missing; please install it.])
fi

dnl Guile-Sqlite3 is used by the (guix store ...) modules.
GUIX_CHECK_GUILE_SQLITE3
if test "x$guix_cv_have_recent_guile_sqlite3" != "xyes"; then
  AC_MSG_ERROR([A recent Guile-SQLite3 could not be found; please install it.])
fi

GUIX_CHECK_GUILE_GCRYPT
if test "x$guix_cv_have_recent_guile_gcrypt" != "xyes"; then
  AC_MSG_ERROR([A recent Guile-Gcrypt could not be found; please install it.])
fi

GUIX_CHECK_GUILE_GIT
if test "x$guix_cv_have_recent_guile_git" != "xyes"; then
  AC_MSG_ERROR([A recent Guile-Git could not be found; please install it.])
fi

dnl Check for the optional Guile-Lib.
GUILE_MODULE_EXPORTS([have_guile_lib], [(htmlprag)], [%strict-tokenizer?])
AM_CONDITIONAL([HAVE_GUILE_LIB], [test "x$have_guile_lib" = "xyes"])
AM_COND_IF(HAVE_GUILE_LIB,,
  [AC_MSG_WARN([The Guile-Lib requirement was not satisfied (>= 0.2.7);
Some features such as the Go importer will not be usable.])])

dnl Check for Guile-zlib.
GUIX_CHECK_GUILE_ZLIB
if test "x$guix_cv_have_recent_guile_zlib" != "xyes"; then
  AC_MSG_ERROR([A recent Guile-zlib could not be found; please install it.])
fi

dnl Check for Guile-lzlib.
GUILE_MODULE_AVAILABLE([have_guile_lzlib], [(lzlib)])
if test "x$have_guile_lzlib" != "xyes"; then
  AC_MSG_ERROR([Guile-lzlib is missing; please install it.])
fi

dnl Check for Guile-Avahi.
GUILE_MODULE_AVAILABLE([have_guile_avahi], [(avahi)])
AM_CONDITIONAL([HAVE_GUILE_AVAHI],
  [test "x$have_guile_avahi" = "xyes"])

dnl Guile-newt is used by the graphical installer.
GUILE_MODULE_AVAILABLE([have_guile_newt], [(newt)])

AC_ARG_ENABLE([installer],
    AS_HELP_STRING([--enable-installer], [Build the graphical installer sources.]))

AS_IF([test "x$enable_installer" = "xyes"], [
if test "x$have_guile_newt" != "xyes"; then
  AC_MSG_ERROR([Guile-newt could not be found; please install it.])
fi
])

AM_CONDITIONAL([ENABLE_INSTALLER],
  [test "x$enable_installer" = "xyes"])

dnl Make sure we have a full-fledged Guile.
GUIX_ASSERT_GUILE_FEATURES([regex posix socket net-db threads])

AC_PROG_SED

dnl Decompressors, for use by the substituter and other modules.
AC_PATH_PROG([GZIP], [gzip])
AC_PATH_PROG([BZIP2], [bzip2])
AC_PATH_PROG([XZ], [xz])
AC_SUBST([GZIP])
AC_SUBST([BZIP2])
AC_SUBST([XZ])

dnl Git is now required for the "builtin:git-download" derivation builder.
AC_PATH_PROG([GIT], [git])
if test "x$GIT" = "x"; then
  AC_MSG_ERROR([Git is missing; please install it.])
fi
AC_SUBST([GIT])

LIBGCRYPT_LIBDIR="no"
LIBGCRYPT_PREFIX="no"

AC_ARG_WITH([libgcrypt-prefix],
  [AS_HELP_STRING([--with-libgcrypt-prefix=DIR], [search for GNU libgcrypt in DIR])],
  [case "$withval" in
    yes|no)
      ;;
    *)
      LIBGCRYPT_PREFIX="$withval"
      LIBGCRYPT_LIBDIR="$withval/lib"
      ;;
   esac])

AC_ARG_WITH([libgcrypt-libdir],
  [AS_HELP_STRING([--with-libgcrypt-libdir=DIR],
     [search for GNU libgcrypt's shared library in DIR])],
  [case "$withval" in
    yes|no)
      LIBGCRYPT_LIBDIR="no"
      ;;
    *)
      LIBGCRYPT_LIBDIR="$withval"
      ;;
   esac])

dnl If none of the --with-libgcrypt-* options was used, try to determine the
dnl the library directory.
case "x$LIBGCRYPT_PREFIX$LIBGCRYPT_LIBDIR" in
  xnono)
    GUIX_LIBGCRYPT_LIBDIR([LIBGCRYPT_LIBDIR])
    ;;
esac

AC_SUBST([LIBGCRYPT_PREFIX])
AC_SUBST([LIBGCRYPT_LIBDIR])

dnl Check for Guile-SSH, for the (guix ssh) module.
GUIX_CHECK_GUILE_SSH
AM_CONDITIONAL([HAVE_GUILE_SSH],
  [test "x$guix_cv_have_recent_guile_ssh" = "xyes"])

AC_CACHE_SAVE

m4_include([config-daemon.ac])

dnl `dot' (from the Graphviz package) is only needed for maintainers.
dnl See `Building from Git' in the manual for more info.
AM_MISSING_PROG([DOT], [dot])

dnl Manual pages.
AM_MISSING_PROG([HELP2MAN], [help2man])

dnl Documentation translation.
AM_MISSING_PROG([PO4A], [po4a])

AC_MSG_CHECKING([if building from git])
if test -e .git; then
   in_git_p=yes
else
   in_git_p=no
fi
AC_MSG_RESULT([$in_git_p])
AM_CONDITIONAL([in_git_p],
  [test "x$in_git_p" = "xyes"])

case "$storedir" in
  /gnu/store)
    ;;
  *)
    AC_MSG_WARN([Using a store directory other than '/gnu/store' will prevent you])
    AC_MSG_WARN([from downloading substitutes from gnu.org.])
    ;;
esac

AC_CONFIG_FILES([Makefile
                 po/guix/Makefile.in
                 po/packages/Makefile.in
                 etc/guix-daemon.cil
                 guix/config.scm])

AC_CONFIG_FILES([etc/committer.scm], [chmod +x etc/committer.scm])
AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
  [chmod +x pre-inst-env])

AC_OUTPUT
iption "Tasty-th automatically generates tasty TestTrees from functions of the current module, using TemplateHaskell. This is a fork the original test-framework-th package, modified to work with tasty instead of test-framework.") (license license:bsd-3))) (define-public ghc-tasty-rerun (package (name "ghc-tasty-rerun") (version "1.1.14") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/tasty-rerun/" "tasty-rerun-" version ".tar.gz")) (sha256 (base32 "0s0zj8ds4g1w2cjzm2lh25ivg962jigqdrbj08v3dbz64lx4mlzr")))) (build-system haskell-build-system) (inputs `(("ghc-optparse-applicative" ,ghc-optparse-applicative) ("ghc-reducers" ,ghc-reducers) ("ghc-split" ,ghc-split) ("ghc-tagged" ,ghc-tagged) ("ghc-tasty" ,ghc-tasty))) (home-page "https://github.com/ocharles/tasty-rerun") (synopsis "Run tests by filtering the test tree") (description "This package adds the ability to run tests by filtering the test tree based on the result of a previous test run. You can use this to run only those tests that failed in the last run, or to only run the tests that have been added since previous test run.") (license license:bsd-3))) (define-public ghc-tasty-expected-failure (package (name "ghc-tasty-expected-failure") (version "0.11.1.2") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "tasty-expected-failure/tasty-expected-failure-" version ".tar.gz")) (sha256 (base32 "175gdk1mkslcwjxajkbl4zmaigzf8h4svzd7va5qb519y0dxk28n")))) (build-system haskell-build-system) (inputs `(("ghc-tagged" ,ghc-tagged) ("ghc-tasty" ,ghc-tasty))) (home-page "https://github.com/nomeata/tasty-expected-failure") (synopsis "Mark tasty tests as failure expected") (description "With the function @code{Test.Tasty.ExpectedFailure.expectFail} in the provided module @code{Test.Tasty.ExpectedFailure}, you can mark that you expect test cases to fail, and not to pass. This can be used for test-driven development.") (license license:expat))) (define-public ghc-quickcheck-instances (package (name "ghc-quickcheck-instances") (version "0.3.22") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "quickcheck-instances/quickcheck-instances-" version ".tar.gz")) (sha256 (base32 "14asr9r7da3w7p4hjj51w2yb002nz8x0np8hdz9z4yjvi60vyrax")))) (build-system haskell-build-system) (arguments `(#:cabal-revision ("2" "1ia5fjhpg7rz793552v88gv2iqx7hl9mi2g09m0llasy1cpzc9jr"))) (inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-base-compat" ,ghc-base-compat) ("ghc-case-insensitive" ,ghc-case-insensitive) ("ghc-hashable" ,ghc-hashable) ("ghc-old-time" ,ghc-old-time) ("ghc-scientific" ,ghc-scientific) ("ghc-tagged" ,ghc-tagged) ("ghc-time-compat" ,ghc-time-compat) ("ghc-transformers-compat" ,ghc-transformers-compat) ("ghc-unordered-containers" ,ghc-unordered-containers) ("ghc-uuid-types" ,ghc-uuid-types) ("ghc-vector" ,ghc-vector))) (home-page "https://github.com/aslatter/qc-instances") (synopsis "Common quickcheck instances") (description "This package provides QuickCheck instances for types provided by the Haskell Platform.") (license license:bsd-3))) (define-public ghc-quickcheck-unicode (package (name "ghc-quickcheck-unicode") (version "1.0.1.0") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/quickcheck-unicode/" "quickcheck-unicode-" version ".tar.gz")) (sha256 (base32 "0s43s1bzbg3gwsjgm7fpyksd1339f0m26dlw2famxwyzgvm0a80k")))) (build-system haskell-build-system) (inputs `(("ghc-quickcheck" ,ghc-quickcheck))) (home-page "https://github.com/bos/quickcheck-unicode") (synopsis "Generator functions Unicode-related tests") (description "This package provides generator and shrink functions for testing Unicode-related software.") (license license:bsd-3))) (define-public ghc-quickcheck-io (package (name "ghc-quickcheck-io") (version "0.2.0") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/quickcheck-io/quickcheck-io-" version ".tar.gz")) (sha256 (base32 "08k4v7pkgjf30pv5j2dfv1gqv6hclxlniyq2sps8zq4zswcr2xzv")))) (build-system haskell-build-system) (inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hunit" ,ghc-hunit))) (home-page "https://github.com/hspec/quickcheck-io#readme") (synopsis "Use HUnit assertions as QuickCheck properties") (description "This package provides an orphan instance that allows you to use HUnit assertions as QuickCheck properties.") (license license:expat))) (define-public ghc-quickcheck (package (name "ghc-quickcheck") (version "2.13.2") (outputs '("out" "static" "doc")) (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/QuickCheck/QuickCheck-" version ".tar.gz")) (sha256 (base32 "0426j43af8v3qmdjjqxivazsvr3a2brac8yw09vpgpjkb2m0nmkv")))) (build-system haskell-build-system) (arguments `(#:tests? #f)) ; FIXME: currently missing libraries used for tests. (inputs `(("ghc-random" ,ghc-random) ("ghc-splitmix" ,ghc-splitmix-bootstrap) ("ghc-tf-random" ,ghc-tf-random))) (home-page "https://github.com/nick8325/quickcheck") (synopsis "Automatic testing of Haskell programs") (description "QuickCheck is a library for random testing of program properties. The programmer provides a specification of the program, in the form of properties which functions should satisfy, and QuickCheck then tests that the properties hold in a large number of randomly generated cases. Specifications are expressed in Haskell, using combinators defined in the QuickCheck library.") (license license:bsd-3))) (define-public ghc-test-framework (package (name "ghc-test-framework") (version "0.8.2.0") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/test-framework/" "test-framework-" version ".tar.gz")) (sha256 (base32 "1hhacrzam6b8f10hyldmjw8pb7frdxh04rfg3farxcxwbnhwgbpm")))) (build-system haskell-build-system) (arguments `(#:tests? #f ; FIXME: Tests do not build. #:cabal-revision ("5" "18g92ajx3ghznd6k3ihj22ln29n676ailzwx3k0f1kj3bmpilnh6"))) (native-inputs `(("ghc-hunit" ,ghc-hunit) ("ghc-quickcheck" ,ghc-quickcheck))) (inputs `(("ghc-ansi-terminal" ,ghc-ansi-terminal) ("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint) ("ghc-hostname" ,ghc-hostname) ("ghc-old-locale" ,ghc-old-locale) ("ghc-random" ,ghc-random) ("ghc-regex-posix" ,ghc-regex-posix) ("ghc-xml" ,ghc-xml) ("ghc-libxml" ,ghc-libxml) ("ghc-semigroups" ,ghc-semigroups-bootstrap))) (home-page "https://batterseapower.github.io/test-framework/") (synopsis "Framework for running and organising tests") (description "This package allows tests such as QuickCheck properties and HUnit test cases to be assembled into test groups, run in parallel (but reported in deterministic order, to aid diff interpretation) and filtered and controlled by command line options. All of this comes with colored test output, progress reporting and test statistics output.") (license license:bsd-3))) (define-public ghc-test-framework-hunit (package (name "ghc-test-framework-hunit") (version "0.3.0.2") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "test-framework-hunit/test-framework-hunit-" version ".tar.gz")) (sha256 (base32 "1y0b6vg8nfm43v90lxxcydhi6qlxhfy4vpxbzm5ic2w55bh8xjwm")))) (build-system haskell-build-system) (arguments `(#:cabal-revision ("3" "0i9mlalv7cl1iq43ld5myrnpszq5rxmd79hk495dcb08rglhgl3z"))) (inputs `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions) ("ghc-hunit" ,ghc-hunit) ("ghc-test-framework" ,ghc-test-framework))) (home-page "https://batterseapower.github.io/test-framework/") (synopsis "HUnit support for test-framework") (description "This package provides HUnit support for the test-framework package.") (license license:bsd-3))) (define-public ghc-test-framework-quickcheck2 (package (name "ghc-test-framework-quickcheck2") (version "0.3.0.5") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "test-framework-quickcheck2/" "test-framework-quickcheck2-" version ".tar.gz")) (sha256 (base32 "0ngf9vvby4nrdf1i7dxf5m9jn0g2pkq32w48xdr92n9hxka7ixn9")))) (build-system haskell-build-system) (arguments `(#:cabal-revision ("1" "1vmpk70h1594h9s216d3ngkb399fpny1d3sh4gg0vrc75p4as68d"))) (inputs `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions) ("ghc-quickcheck" ,ghc-quickcheck) ("ghc-random" ,ghc-random) ("ghc-test-framework" ,ghc-test-framework))) (home-page "https://batterseapower.github.io/test-framework/") (synopsis "QuickCheck2 support for test-framework") (description "This package provides QuickCheck2 support for the test-framework package.") (license license:bsd-3))) (define-public ghc-test-framework-th (package (name "ghc-test-framework-th") (version "0.2.4") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "test-framework-th-" version "/" "test-framework-th-" version ".tar.gz")) (sha256 (base32 "12lw7yj02jb9s0i7rb98jjam43j2h0gzmnbj9zi933fx7sg0sy4b")))) (build-system haskell-build-system) (inputs `(("ghc-test-framework" ,ghc-test-framework) ("ghc-language-haskell-extract" ,ghc-language-haskell-extract) ("ghc-haskell-src-exts" ,ghc-haskell-src-exts) ("ghc-regex-posix" ,ghc-regex-posix))) (home-page "https://github.com/finnsson/test-generator") (synopsis "Auto generate the HUnit- and Quickcheck-bulk-code using Template Haskell") (description "This library contains two functions: @code{defaultMainGenerator} and @code{testGroupGenerator}. @code{defaultMainGenerator} will extract all functions beginning with @code{case_}, @code{prop_}, or @code{test_} in the module and put them in a @code{testGroup}. @code{testGroupGenerator} is like @code{defaultMainGenerator} but without @code{defaultMain}. It is useful if you need a function for the testgroup \(e.g. if you want to be able to call the testgroup from another module).") (license license:bsd-3))) (define-public ghc-hunit (package (name "ghc-hunit") (version "1.6.0.0") (outputs '("out" "static" "doc")) (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/HUnit/" "HUnit-" version ".tar.gz")) (sha256 (base32 "1pnhwqq5v8h48gbp3ibv3skfj25mf4zs5svxcavq93p9cswycj3l")))) (build-system haskell-build-system) (inputs ;; We cannot use ghc-call-stack there, because it depends on ;; ghc-nanospec, which depends on ghc-hunit. `(("ghc-call-stack" ,ghc-call-stack-boot))) (home-page "http://hunit.sourceforge.net/") (synopsis "Unit testing framework for Haskell") (description "HUnit is a unit testing framework for Haskell, inspired by the JUnit tool for Java.") (license license:bsd-3))) (define-public hspec-discover (package (name "hspec-discover") (version "2.7.1") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "hspec-discover/hspec-discover-" version ".tar.gz")) (sha256 (base32 "0r47fm94wa6qrhp8cc1zzkjrxc32rnagfn9m9ga4dm6p6ydw4c8b")))) (build-system haskell-build-system) (native-inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hspec-meta" ,ghc-hspec-meta))) (home-page "https://hspec.github.io/") (synopsis "Automatically discover and run Hspec tests") (description "hspec-discover is a tool which automatically discovers and runs Hspec tests.") (license license:expat))) (define-public ghc-hspec-core (package (name "ghc-hspec-core") (version "2.7.1") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/hspec-core/" "hspec-core-" version ".tar.gz")) (sha256 (base32 "08vk8588lap00hsln8zl64dazbb28lzk4b4h5vnm7xvhg7r21k1c")))) (build-system haskell-build-system) (arguments `(#:tests? #f)) ; FIXME: testing libraries are missing. (inputs `(("ghc-setenv" ,ghc-setenv) ("ghc-ansi-terminal" ,ghc-ansi-terminal) ("ghc-clock" ,ghc-clock) ("ghc-quickcheck-io" ,ghc-quickcheck-io) ("ghc-hunit" ,ghc-hunit) ("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hspec-expectations" ,ghc-hspec-expectations) ("ghc-silently" ,ghc-silently) ("ghc-tf-random" ,ghc-tf-random))) (home-page "https://hspec.github.io/") (synopsis "Testing framework for Haskell") (description "This library exposes internal types and functions that can be used to extend Hspec's functionality.") (license license:expat))) (define-public ghc-hspec-meta (package (name "ghc-hspec-meta") (version "2.6.0") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/hspec-meta/" "hspec-meta-" version ".tar.gz")) (sha256 (base32 "1n1a4633wfivylglji8920f67mx7qz8j4q58n8p7dxk6yg4h3mz6")))) (build-system haskell-build-system) (inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hunit" ,ghc-hunit) ("ghc-ansi-terminal" ,ghc-ansi-terminal) ("ghc-clock" ,ghc-clock) ("ghc-hspec-expectations" ,ghc-hspec-expectations) ("ghc-setenv" ,ghc-setenv) ("ghc-random" ,ghc-random) ("ghc-quickcheck-io" ,ghc-quickcheck-io))) (home-page "https://hspec.github.io/") (synopsis "Version of Hspec to test Hspec itself") (description "This library provides a stable version of Hspec which is used to test the in-development version of Hspec.") (license license:expat))) (define-public ghc-hspec (package (name "ghc-hspec") (version "2.7.1") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/hspec/" "hspec-" version ".tar.gz")) (sha256 (base32 "1x8rcr7j1azcaw0fg1xzp8j0gr4ias36z09aj24i4xp8pnyfp341")))) (build-system haskell-build-system) (outputs '("out" "static" "doc")) (inputs `(("ghc-hspec-core" ,ghc-hspec-core) ("hspec-discover" ,hspec-discover) ("ghc-hspec-expectations" ,ghc-hspec-expectations) ("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hunit" ,ghc-hunit) ("ghc-stringbuilder" ,ghc-stringbuilder) ("ghc-hspec-meta" ,ghc-hspec-meta))) (home-page "https://hspec.github.io/") (synopsis "Testing Framework for Haskell") (description "This library provides the Hspec testing framework for Haskell, inspired by the Ruby library RSpec.") (license license:expat))) (define-public ghc-hspec-contrib (package (name "ghc-hspec-contrib") (version "0.5.1") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "hspec-contrib/hspec-contrib-" version ".tar.gz")) (sha256 (base32 "0hhzxaa3fxz5mk5qcsrnfr98a7bn3szx2ydgr0x9mbqmm1jg06rc")))) (build-system haskell-build-system) (inputs `(("ghc-hspec-core" ,ghc-hspec-core) ("ghc-hunit" ,ghc-hunit) ("ghc-hspec" ,ghc-hspec) ("ghc-quickcheck" ,ghc-quickcheck))) (native-inputs `(("hspec-discover" ,hspec-discover))) (home-page "https://hspec.github.io/") (synopsis "Contributed functionality for Hspec") (description "This package provides contributed Hspec extensions.") (license license:expat))) (define-public ghc-hspec-expectations (package (name "ghc-hspec-expectations") (version "0.8.2") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "hspec-expectations/hspec-expectations-" version ".tar.gz")) (sha256 (base32 "1vxl9zazbaapijr6zmcj72j9wf7ka1pirrjbwddwwddg3zm0g5l1")))) (build-system haskell-build-system) ;; Tests depend on ghc-nanospec. (arguments '(#:tests? #f)) (inputs `(("ghc-hunit" ,ghc-hunit))) (home-page "https://github.com/sol/hspec-expectations") (synopsis "Catchy combinators for HUnit") (description "This library provides catchy combinators for HUnit, see @uref{https://github.com/sol/hspec-expectations#readme, the README}.") (license license:expat))) (define-public ghc-nanospec (package (name "ghc-nanospec") (version "0.2.2") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "nanospec/nanospec-" version ".tar.gz")) (sha256 (base32 "1rcmhl9bhyfvanalnf1r86wkx6rq6wdvagnw1h011jcnnb1cq56g")))) (build-system haskell-build-system) (inputs `(("ghc-hspec" ,ghc-hspec) ("ghc-silently" ,ghc-silently))) (home-page "https://github.com/hspec/nanospec#readme") (synopsis "Lightweight implementation of a subset of Hspec's API") (description "Nanospec is a lightweight implementation of a subset of Hspec's API with minimal dependencies.") (license license:expat))) (define-public ghc-crypto-cipher-tests (package (name "ghc-crypto-cipher-tests") (version "0.0.11") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "crypto-cipher-tests-" version "/" "crypto-cipher-tests-" version ".tar.gz")) (sha256 (base32 "19wqignlq90qwpam01hnmmrxaxh5lkax9l1l6rlbi4a07nvp1dnz")))) (build-system haskell-build-system) (inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-hunit" ,ghc-hunit) ("ghc-test-framework" ,ghc-test-framework) ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2) ("ghc-test-framework-hunit" ,ghc-test-framework-hunit) ("ghc-byteable" ,ghc-byteable) ("ghc-securemem" ,ghc-securemem) ("ghc-crypto-cipher-types" ,ghc-crypto-cipher-types))) (home-page "https://github.com/vincenthz/hs-crypto-cipher") (synopsis "Generic cryptography cipher tests for Haskell") (description " This Haskell package contains generic tests for cryptographic ciphers, and is used by the test runners of various Haskell implementations of cryptographic ciphers.") (license license:bsd-3))) (define-public ghc-hedgehog (package (name "ghc-hedgehog") (version "1.0.1") (source (origin (method url-fetch) (uri (string-append "mirror://hackage/package/hedgehog/hedgehog-" version ".tar.gz")) (sha256 (base32 "1qc7hkqbnsk3f5r26wc35r3qiy941nmcxhfqgcq9027kw4gs0bi0")))) (build-system haskell-build-system) (inputs `(("ghc-ansi-terminal" ,ghc-ansi-terminal) ("ghc-async" ,ghc-async) ("ghc-concurrent-output" ,ghc-concurrent-output) ("ghc-exceptions" ,ghc-exceptions) ("ghc-fail" ,ghc-fail) ("ghc-lifted-async" ,ghc-lifted-async) ("ghc-mmorph" ,ghc-mmorph) ("ghc-monad-control" ,ghc-monad-control) ("ghc-pretty-show" ,ghc-pretty-show) ("ghc-primitive" ,ghc-primitive) ("ghc-random" ,ghc-random) ("ghc-resourcet" ,ghc-resourcet) ("ghc-semigroups" ,ghc-semigroups) ("ghc-th-lift" ,ghc-th-lift) ("ghc-transformers-base" ,ghc-transformers-base) ("ghc-wl-pprint-annotated" ,ghc-wl-pprint-annotated))) (home-page "https://hedgehog.qa") (synopsis "Property-based testing in the spirt of QuickCheck") (description "Hedgehog is a property-based testing system, in the spirit of QuickCheck. Hedgehog uses integrated shrinking, so shrinks obey the invariants of generated values by construction. To get started quickly, see the examples: @uref{https://github.com/hedgehogqa/haskell-hedgehog/tree/master/hedgehog-example}") (license license:bsd-3))) (define-public cabal-doctest (package (name "cabal-doctest") (version "1.0.8") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "cabal-doctest/cabal-doctest-" version ".tar.gz")) (sha256 (base32 "03if74imlhhk7m56nci5f1wclniwqdmwl4hl177040j1gnlac9i0")))) (build-system haskell-build-system) (home-page "https://github.com/phadej/cabal-doctest") (synopsis "Setup.hs helper for running doctests") (description "To properly work, the @code{doctest} package needs plenty of configuration. This library provides the common bits for writing custom @file{Setup.hs} files.") (license license:bsd-3))) (define-public ghc-testing-type-modifiers (package (name "ghc-testing-type-modifiers") (version "0.1.0.1") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "testing-type-modifiers/testing-type-modifiers-" version ".tar.gz")) (sha256 (base32 "1wh2n95n39ivv6kbqn42vbzrj8zagsmk6f2al2qj40bg5kgdl2q5")))) (build-system haskell-build-system) (home-page "https://hackage.haskell.org/package/testing-type-modifiers") (synopsis "Data type modifiers for property based testing") (description "Property based testing libraries such as QuickCheck tend to include type modifiers. Most of them are used to quantify over subsets of a type. This library is intended to supply these modifiers to be used by testing libraries, in an effort to make properties more portable between testing frameworks.") (license license:unlicense))) (define-public ghc-testing-feat (package (name "ghc-testing-feat") (version "1.1.0.0") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/" "testing-feat/testing-feat-" version ".tar.gz")) (sha256 (base32 "1v2qzzpf1s008g7q6q67glf7vbm1pkpq4rc3ii74f4g6vhfx610r")))) (build-system haskell-build-system) (inputs `(("ghc-quickcheck" ,ghc-quickcheck) ("ghc-size-based" ,ghc-size-based) ("ghc-testing-type-modifiers" ,ghc-testing-type-modifiers) ("ghc-semigroups" ,ghc-semigroups))) (home-page "https://github.com/JonasDuregard/testing-feat") (synopsis "Functional Enumeration of Algebraic Types") (description "Feat (Functional Enumeration of Algebraic Types) provides enumerations as functions from natural numbers to values (similar to @code{toEnum} but for any algebraic data type). This can be used for SmallCheck-style systematic testing, QuickCheck-style random testing, and hybrids of the two.") (license license:bsd-3))) (define-public ghc-inspection-testing (package (name "ghc-inspection-testing") (version "0.4.2.2") (source (origin (method url-fetch) (uri (string-append "https://hackage.haskell.org/package/inspection-testing/" "inspection-testing-" version ".tar.gz")) (sha256 (base32 "1bppz99p6ix6hah8lbr9mapl2zxgmkg9i7h6hk8wq6zf54hwz3yp")))) (build-system haskell-build-system) (home-page "https://github.com/nomeata/inspection-testing") (synopsis "GHC plugin to do inspection testing") (description "Some carefully crafted libraries make promises to their users beyond functionality and performance. Examples are: Fusion libraries promise intermediate data structures to be eliminated. Generic programming libraries promise that the generic implementation is identical to the hand-written one. Some libraries may promise allocation-free or branch-free code. Conventionally, the modus operandi in all these cases is that the library author manually inspects the (intermediate or final) code produced by the compiler. This is not only tedious, but makes it very likely that some change, either in the library itself or the surrounding eco-system, breaks the library's promised without anyone noticing. This package provides a disciplined way of specifying such properties, and have them checked by the compiler. This way, this checking can be part of the ususal development cycle and regressions caught early. See the documentation in \"Test.Inspection\" or the project webpage for more examples and more information.") (license license:expat)))