;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Arun Isaac ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ham-radio) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (gnu packages libusb) #:use-module (gnu packages pkg-config) #:use-module (guix build-system cmake)) (define-public rtl-sdr (package (name "rtl-sdr") (version "0.5.3") (source (origin (method url-fetch) (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-" version ".tar.xz")) (sha256 (base32 "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9")))) (build-system cmake-build-system) (inputs `(("libusb" ,libusb))) (native-inputs `(("pkg-config" ,pkg-config))) (arguments `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON") #:tests? #f)) ; No tests (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr") (synopsis "Software defined radio driver for Realtek RTL2832U") (description "DVB-T dongles based on the Realtek RTL2832U can be used as a cheap software defined radio, since the chip allows transferring the raw I/Q samples to the host. @code{rtl-sdr} provides drivers for this purpose.") (license license:gpl2+))) ass='path'>path: root/gnu/packages/libidn.scm
17:32:42 -0600'>2017-11-06
AgeCommit message (Expand)Author
2020-09-21installer: Fix docstring typoes....Tobias Geerinckx-Rice
gnu: Disable gnulib's test-lock test in packages....Eric Bavier
2017-10-01Merge remote-tracking branch 'origin/master' into core-updatesEfraim Flashner
2017-09-04gnu: libidn2: Replace with 2.0.4 [security fixes]....Mark H Weaver
2017-08-30gnu: libidn2: Update to 2.0.4....Efraim Flashner
2017-05-22gnu: libidn2: Update to 2.0.2....Marius Bakke
2017-04-23gnu: libidn2: Update to 2.0.1....Efraim Flashner
2017-03-30Merge branch 'master' into core-updates...Marius Bakke
2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....Tobias Geerinckx-Rice
2017-03-14gnu: libidn2: Create 'pkg-config' file....Marius Bakke
2017-02-06gnu: libidn2: Update to 0.16....Leo Famulari
2016-11-06Merge branch 'master' into core-updatesMark H Weaver
2016-11-05gnu: libidn: Distinguish from libidn2....Leo Famulari
2016-11-05gnu: Add libidn2....Leo Famulari
2016-09-02gnu: libidn: Replace with 1.33 [fixes CVE-2015-8948 and CVE-2016-{6261,6263}]....Leo Famulari
2016-08-14gnu: libidn: Update to 1.33....Leo Famulari