;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Arun Isaac ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ham-radio) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (gnu packages libusb) #:use-module (gnu packages pkg-config) #:use-module (guix build-system cmake)) (define-public rtl-sdr (package (name "rtl-sdr") (version "0.5.3") (source (origin (method url-fetch) (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-" version ".tar.xz")) (sha256 (base32 "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9")))) (build-system cmake-build-system) (inputs `(("libusb" ,libusb))) (native-inputs `(("pkg-config" ,pkg-config))) (arguments `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON") #:tests? #f)) ; No tests (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr") (synopsis "Software defined radio driver for Realtek RTL2832U") (description "DVB-T dongles based on the Realtek RTL2832U can be used as a cheap software defined radio, since the chip allows transferring the raw I/Q samples to the host. @code{rtl-sdr} provides drivers for this purpose.") (license license:gpl2+))) 2ccd2d5ee96facaf810aa5cffba36ca'>root/tests/monads.scm
ommit message (Expand)
AgeCommit message (Expand)Author
Author
2020-11-07Merge branch 'master' into staging...Marius Bakke
2020-10-27gnu: khal: Skip the test suite....Leo Famulari
2020-10-26gnu: khal: Update to 0.10.2....Lars-Dominik Braun
2020-10-19Merge branch 'master' into stagingMarius Bakke
2020-10-19gnu: Add ccal....Peng Mei Yu
2020-09-21gnu: libical: Use local docbook-xml package....Efraim Flashner
2020-09-05Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner
2020-08-05gnu: Add confclerk....Efraim Flashner
2020-07-25gnu: libical: Disable parallel build....Marius Bakke