;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs `(("gtk+" ,gtk+))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (home-page "https://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) 08ec5fb96a1fbdc144f5585af49668960dfc8'>packages/android.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-25 19:47:38 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-27 20:14:05 +0100
commite3908ec5fb96a1fbdc144f5585af49668960dfc8 (patch)
tree07113e24fc0d4e394b422b3921095fee23a687ba /gnu/packages/android.scm
parentfc6bced6c5d325aeb8c748464cf9addfd61c71c8 (diff)
downloadguix-e3908ec5fb96a1fbdc144f5585af49668960dfc8.tar.gz
guix-e3908ec5fb96a1fbdc144f5585af49668960dfc8.zip
gnu: plasma-framework: Fix build errors in dependent packages.
Fix build errors in dependent packages if PREFIX is different from ECM's PREFIX - which is the case in Guix. See <https://bugs.kde.org/424483> for details. * gnu/packages/patches/plasma-framework-fix-KF5PlasmaMacros.cmake.patch: New file. * gnu/local.mk (dist_patch_DATA) Add it. * packages/kde-frameworks.scm (plasma-framework)[source]: Use this patch.
Diffstat (limited to 'gnu/packages/android.scm')
0 files changed, 0 insertions, 0 deletions