;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs (list gtk+)) (native-inputs (list intltool pkg-config)) (home-page "https://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) div class='content'>
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-06-22 09:11:39 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:36 +0200
commit3d341a057f280eaa032f2371bf01b918c3e228e4 (patch)
tree1746c331e791c81bbc994965f7f11637b11396f0 /gnu/packages
parent72aad6627f8532162713c21700ae16d05bbaba93 (diff)
downloadguix-3d341a057f280eaa032f2371bf01b918c3e228e4.tar.gz
guix-3d341a057f280eaa032f2371bf01b918c3e228e4.zip
gnu: texlive-match-parens: Specify upstream name.
* gnu/packages/tex.scm (texlive-match-parens)[properties]: Add UPSTREAM-NAME property. Change-Id: I831df8be99fd781724fa4bd5d7d2d8abf4d15101
Diffstat (limited to 'gnu/packages')