;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs (list gtk+)) (native-inputs (list intltool pkg-config)) (home-page "https://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) >packages/connman.scm
AgeCommit message (Expand)Author
2022-09-19gnu: connman: Patch CVE-2022-32392, CVE-2022-32293.Efraim Flashner
2022-07-31gnu: qttools: Rename to qttools-5.Maxim Cournoyer
2022-07-06gnu: connman: Fix cross-compilation.Jean-Pierre De Jesus DIAZ
2022-02-07gnu: connman: Update to 1.41.Efraim Flashner
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-07-18Merge branch 'master' into core-updatesLudovic Courtès
2021-06-25gnu: connman: Update to 1.40.Tobias Geerinckx-Rice
2021-06-19Merge branch 'master' into core-updatesMarius Bakke
2021-06-14gnu: Rename qtbase to qtbase-5.Maxim Cournoyer
2021-06-13gnu: connman: Fix CVE-2021-33833.Leo Famulari
2021-02-11Merge branch 'master' into core-updatesDanny Milosavljevic
2021-02-08gnu: connman: Update to 1.39 [fixes CVE-2021-{26675,26676}].Leo Famulari
2021-02-03Merge branch 'master' into core-updatesChristopher Baines
2021-02-01gnu: Adjust package collection to Wrap using GUIX_PYTHONPATH.Maxim Cournoyer
2021-01-31gnu: cmst: Update to 2020.11.01.Efraim Flashner