;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "2.20.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "1b75qjx339c7q0xfxnwb2n5vw6xn8vi6nw2clggfzxnwwx58g2d1")))) (build-system gnu-build-system) (inputs `(("gtk+" ,gtk+-2))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (home-page "http://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) '/>
AgeCommit message (Expand)Author
2022-10-24gnu: libidn2: Update to 2.3.4.Efraim Flashner
2022-08-27gnu: libidn2: Update to 2.3.3.Marius Bakke
2022-06-26gnu: libidn: Update to 1.41.Marius Bakke
2022-01-24gnu: libidn: Update to 1.38.Efraim Flashner
2022-01-24gnu: libidn2: Update to 2.3.2.Efraim Flashner
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-05-15gnu: libidn: Update to 1.37.Efraim Flashner
2021-05-13gnu: libidn2: Update to 2.3.1.Efraim Flashner
2020-08-02gnu: libidn: Update to 1.36.Michael Rohleder