;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs `(("gtk+" ,gtk+))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (home-page "http://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) FILES.in?id=0847e479f6c8ade3a2deecdf8efe0f18d0efc4d5'>POTFILES.in
AgeCommit message (Expand)Author
2017-11-28services: certbot: Add default value and description....Ludovic Courtès
2017-11-28services: cgit, git-daemon: Add description and default value....Ludovic Courtès
2017-09-16services: networking: Add descriptions....Ludovic Courtès
2017-09-16services: base: Add descriptions....Ludovic Courtès
2017-07-15nls: Adjust to qemu.scm renaming....宋文武
2017-06-20gnu: Move contents of zip module into compression module....Arun Isaac
2016-12-05nls: Adjust to geeqie.scm removal....Ludovic Courtès
2016-12-04nls: Adjust to feh.scm renaming....Ludovic Courtès
2016-08-04nls: Adjust to zsh.scm renaming....Ludovic Courtès
2016-05-26nls: Adjust to texlive.scm renaming....Ludovic Courtès
2016-03-03po: Drop removed file 'weechat.scm'....Justus Winter
2015-07-19nls: Add package files for translation....Ludovic Courtès
2015-05-10nls: Add package files for translation....Ludovic Courtès