;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs (list gtk+)) (native-inputs (list intltool pkg-config)) (home-page "https://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) /log/gnu/packages/vpn.scm?id=bf0f9dd051919f1f66d7f48b1724a1e4a0e37795'>vpn.scm
AgeCommit message (Expand)Author
2021-06-20gnu: openvpn: Update to 2.5.3....Solene Rapenne
2021-06-19gnu: Add missing imports to (gnu packages vpn)....Tobias Geerinckx-Rice
2021-06-19gnu: Move strongswan to (gnu packages vpn)....Tobias Geerinckx-Rice
2021-04-27gnu: wireguard-tools: Update to 1.0.20210424....Tobias Geerinckx-Rice
2021-04-22gnu: openvpn: Update to 2.5.2....Tobias Geerinckx-Rice
2021-04-22gnu: openconnect-sso: Update to 0.7.3....Tobias Geerinckx-Rice
2021-04-13gnu: openconnect-sso: Update to 0.7.2....Efraim Flashner
2021-03-29gnu: wireguard-tools: Update to 1.0.20210315....Tobias Geerinckx-Rice
2021-03-13gnu: wireguard-tools: Update to 1.0.20210223....Tobias Geerinckx-Rice
2021-03-11gnu: openvpn: Update to 2.5.1 [security fixes]....Léo Le Bouter
2021-02-15gnu: Add openconnect-sso....Efraim Flashner
2021-01-10Merge branch 'master' into stagingEfraim Flashner
2021-01-03gnu: wireguard-linux-compat: Update to 1.0.20201221....Tobias Geerinckx-Rice