;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 John Darrington ;;; Copyright © 2016 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gxmessage) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages glib) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gtk) #:use-module (gnu packages)) (define-public gxmessage (package (name "gxmessage") (version "3.4.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gxmessage/gxmessage-" version ".tar.gz")) (sha256 (base32 "01ggvvp0nyn8xczh93icifnji468wsjgqzd1f1bixwsqziaicknv")))) (build-system gnu-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-before 'install 'skip-gtk-update-icon-cache ;; Don't create 'icon-theme.cache'. (lambda _ (substitute* "Makefile" (("gtk-update-icon-cache") "true")) #t))))) (inputs `(("gtk+" ,gtk+))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (home-page "https://www.gnu.org/software/gxmessage/") (synopsis "Open popup message window with buttons for return") (description "GNU gxmessage is a program that pops up dialog windows, which display a message to the user and waits for their action. The program then exits with an exit code corresponding to the response.") (license gpl3+))) cm?id=01cf99af9ccd4977fd46549b99172299814cdc6a'>avahi.scm
AgeCommit message (Expand)Author
2020-10-13gnu: libcap: Make 'libcap/next' the default libcap....Marius Bakke
2020-03-18gnu: avahi: Update to 0.8....Marius Bakke
2020-03-18gnu: avahi: Do not build the static libraries....Marius Bakke
2020-01-21Merge branch 'staging' into core-updatesMarius Bakke
2020-01-19gnu: Use HTTPS for avahi.org everywhere....Tobias Geerinckx-Rice
2019-12-05gnu: avahi: Incorporate grafted changes....Marius Bakke
2019-10-23gnu: avahi: Don't use package/inherit....Tobias Geerinckx-Rice
2019-10-23gnu: avahi: Fix CVE-2018-1000845 and duplicate CVE-2017-6519....Tobias Geerinckx-Rice
2019-01-16gnu: Move dbm databases to new module....Ricardo Wurmus
2018-05-01gnu: nss-mdns: Update to 0.14.1....Ludovic Courtès