;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages groff) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages) #:use-module (gnu packages bison) #:use-module (gnu packages ghostscript) #:use-module (gnu packages netpbm) #:use-module (gnu packages perl) #:use-module (gnu packages texinfo)) (define-public groff (package (name "groff") (version "1.22.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/groff/groff-" version ".tar.gz")) (sha256 (base32 "1998v2kcs288d3y7kfxpvl369nqi06zbbvjzafyvyl3pr7bajj1s")))) (build-system gnu-build-system) (outputs '("out" "doc")) ;12MiB of PS, PDF, HTML, and examples (inputs `(("ghostscript" ,ghostscript) ("netpbm" ,netpbm))) (native-inputs `(("bison" ,bison) ("perl" ,perl) ("psutils" ,psutils) ("texinfo" ,texinfo))) (arguments '(#:parallel-build? #f)) ; parallel build fails (synopsis "Typesetting from plain text mixed with formatting commands") (description "Groff is a typesetting package that reads plain text and produces formatted output based on formatting commands contained within the text. It is usually the formatter of \"man\" documentation pages.") (license gpl3+) (home-page "http://www.gnu.org/software/groff/"))) dd333d570b54c2ba34c9c14a9'>gnupg.scm
AgeCommit message (Expand)Author
2022-12-27gnu: libksba: Update replacement to 1.6.3 [fixes CVE-2022-47629].Simon Josefsson
2022-12-02gnu: guile-gcrypt: Update to 0.4.0.Ludovic Courtès
2022-11-22gnu: gpgme: Add 1.18.0.Marius Bakke
2022-10-30gnu: jetring: Update to 0.31.Tobias Geerinckx-Rice
2022-10-23gnu: pinentry-tty: Update to 1.2.1.Tobias Geerinckx-Rice
2022-10-16gnu: libksba: Graft to 1.6.2 [fixes CVE-2022-3515].Tobias Geerinckx-Rice
2022-08-29gnu: gnupg: Use mirror URL.Maxime Devos
2022-08-09gnu: gnupg: Patch CVE-2022-34903.Efraim Flashner
2022-05-29gnu: pgpdump: Update to 0.35.Tobias Geerinckx-Rice
2022-05-31gnu: pius: Update to 3.0.0.Maxim Cournoyer
2022-05-31gnu: Remove python2-pygpgme.Maxim Cournoyer
2022-05-31gnu: Remove python2-gpg.Maxim Cournoyer
2022-01-17Merge branch 'version-1.4.0'Maxim Cournoyer
2022-01-10gnu: python-gnupg: Update to 0.4.8.Maxim Cournoyer
2022-01-10gnu: gnupg: Update to 2.2.32.Maxim Cournoyer
2022-01-14gnu: parcimonie: Help find new releases.Efraim Flashner
2022-01-14gnu: parcimonie: Remove input labels.Efraim Flashner
2022-01-14gnu: parcimonie: Update to 0.12.0.Efraim Flashner