;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "https://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) (define-public gperf-3.0 ;; This older version would use 'unsigned int' in its generated lookup ;; functions whereas 3.1 uses 'size_t', which causes breakage such as ;; . (package (inherit gperf) (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))))) vm.scm
AgeCommit message (Expand)Author
2019-03-13Remove traces of "GuixSD"....Ludovic Courtès
2018-12-19vm: Re-enable KVM on i386....Ludovic Courtès
2018-12-06vm: Add padding in the ISO image....Ludovic Courtès
2018-11-06pack: Import (guix store database) only when '--localstatedir' is passed....Ludovic Courtès
2018-07-04vm: Disable KVM on i386....Ludovic Courtès
2018-06-26vm: 'make-iso9660-image' makes 'grub.cfg' a GC root....Ludovic Courtès
2018-06-26vm: 'make-iso9660-image' no longer includes unreferenced store items....Ludovic Courtès
2018-06-26vm: Don't try to modify the bind-mounted store....Ludovic Courtès
2018-06-14Remove 'guix-register' and its traces....Ludovic Courtès
2018-06-14install: Use 'reset-timestamps' from (guix store database)....Ludovic Courtès
2018-06-14install: Use (guix store database) instead of 'guix-register'....Ludovic Courtès
2018-05-25vm: Pass "panic=1" to Linux....Ludovic Courtès
2018-05-23vm: Print the label and UUID of partitions....Ludovic Courtès
2018-03-24gnu: When building in a VM, share a temporary directory....Chris Marusich
2018-03-24vm: Allow control of deduplication in root-partition-initializer....Chris Marusich
2018-03-16vm: Pass "-append ..." only once....Danny Milosavljevic
2018-03-15vm: Use 'invoke' instead of 'system*'....Ludovic Courtès