;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "https://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) (define-public gperf-3.0 ;; This older version would use 'unsigned int' in its generated lookup ;; functions whereas 3.1 uses 'size_t', which causes breakage such as ;; . (package (inherit gperf) (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))))) ?id=1bd6b91368b49cc2dde21f62b6e57e65fedea524'>ncdu.scm
AgeCommit message (Expand)Author
2023-04-27gnu: ncdu-1: Update to 1.18.1.Efraim Flashner
2023-02-09gnu: ncdu: Update to 2.2.2.Efraim Flashner
2023-02-09gnu: zig: Update to 0.10.1.Efraim Flashner
2022-12-11gnu: ncdu: Use upstream name.Tobias Geerinckx-Rice
2022-12-11gnu: ncdu2: Delete pregenerated man page from source.Tobias Geerinckx-Rice
2022-12-11gnu: ncdu2: Do not use the illegal instructions.Tobias Geerinckx-Rice
2022-12-15gnu: ncdu: Update to 1.18.Efraim Flashner
2022-11-01gnu: ncdu-2: Update to 2.2.1.Efraim Flashner
2022-10-18gnu: ncdu-2: Update to 2.2.Efraim Flashner
2022-05-10gnu: ncdu: Update to 1.17.Efraim Flashner
2022-05-06gnu: ncdu-2: Update to 2.1.2.Efraim Flashner
2022-03-30gnu: ncdu-2: Update to 2.1.1.Efraim Flashner
2022-03-30gnu: ncdu2: Set upstream name.Efraim Flashner
2022-03-15gnu: ncdu2: Update to 2.1.Efraim Flashner
2022-03-06gnu: Add ncdu2.Efraim Flashner
2021-12-13gnu: Simplify package inputs.Ludovic Courtès