;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "http://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) 5545b97556b7f7f196bda6ca84e3dfa3'/>
AgeCommit message (Expand)Author
2024-02-13gnu: opencv: Update to 4.8.1....Andy Tai
2024-02-09gnu: vxl: Update to 3.5.0....Felix Gruber
2024-01-19gnu: gmic: Update to 3.3.3....Vinicius Monego
2023-12-05gnu: python-imgviz: Adjust for newer python....Efraim Flashner
2023-11-14gnu: insight-toolkit-4.12: Fix building....Efraim Flashner
2023-09-24gnu: opencv: Add descriptors for xfeatures2d....Ricardo Wurmus
2023-08-31gnu: vtk-7: Fix build....宋文武
2023-08-29gnu: opencv: Update to 4.8.0...Andy Tai
2023-08-15gnu: nip2: Build with librsvg-for-system....Efraim Flashner
2023-08-15gnu: vips: Build with librsvg-for-system....Efraim Flashner