;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "https://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) (define-public gperf-3.0 ;; This older version would use 'unsigned int' in its generated lookup ;; functions whereas 3.1 uses 'size_t', which causes breakage such as ;; . (package (inherit gperf) (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))))) 51207339508789b28ba7cb914f983319920f'>php.scm
AgeCommit message (Expand)Author
2023-03-04gnu: Remove and deprecate tidy for tidy-html...Morgan Smith
2023-02-19gnu: php: Drop a failed test for riscv64....Aleksandr Vityazev
2023-02-11gnu: php: Update to 8.2.2....Julien Lepiller
2022-09-18gnu: Explicitly use OpenSSL 1.1 in packages that don't support 3.0....Marius Bakke
2022-07-23gnu: PHP: Fix test failure with newer cURL....Marius Bakke
2022-07-23gnu: PHP: Update to 7.4.30....Marius Bakke
2021-12-16gnu: php: Properly fix openssl_x509_checkpurpose_basic.phpt....Tobias Geerinckx-Rice
2021-12-16gnu: php: Disable yet another failing test....Tobias Geerinckx-Rice
2021-12-05Merge remote-tracking branch 'origin/master' into core-updates-frozenRicardo Wurmus
2021-11-28gnu: php: Remove extra glibc input....Efraim Flashner
2021-11-28gnu: php: Update to 7.4.26....Efraim Flashner
2021-10-31Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner
2021-10-23gnu: php: Update to 7.4.25 [security fixes]....Tobias Geerinckx-Rice
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-10-05gnu: php: Patch failing test case....Ryan Sundberg via Guix-patches via
2021-09-08gnu: php: Disable failing test....Guillaume Le Vaillant
2021-09-06gnu: php: Remove watchpoint tests on powerpc64le....Thiago Jung Bauermann