;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "https://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) (define-public gperf-3.0 ;; This older version would use 'unsigned int' in its generated lookup ;; functions whereas 3.1 uses 'size_t', which causes breakage such as ;; . (package (inherit gperf) (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))))) kages/tryton.scm?id=8734851a8c7bf39f4e88129c3e3de9074fddc3ea'>tryton.scm
AgeCommit message (Expand)Author
2022-08-10gnu: Add trytond-web-shop-shopify....Hartmut Goebel
2022-08-10gnu: Add trytond-stock-package-shipping-sendcloud....Hartmut Goebel
2022-08-10gnu: Add trytond-stock-package-shipping-mygls....Hartmut Goebel
2022-08-10gnu: Add trytond-sale-point....Hartmut Goebel
2022-08-10gnu: Add trytond-product-image-attribute....Hartmut Goebel
2022-08-10gnu: Add trytond-product-image....Hartmut Goebel
2022-08-10gnu: Add trytond-currency-rs....Hartmut Goebel
2022-08-10gnu: Add trytond-currency-ro....Hartmut Goebel
2022-08-10gnu: Add trytond-analytic-budget....Hartmut Goebel
2022-08-10gnu: Add trytond-account-stock-shipment-cost....Hartmut Goebel
2022-08-10gnu: Add trytond-account-rule....Hartmut Goebel
2022-08-10gnu: Add trytond-account-move-line-grouping....Hartmut Goebel
2022-08-10gnu: Add trytond-account-budget....Hartmut Goebel
2022-08-10gnu: Tryton application and framework: Update to 6.2.x....Hartmut Goebel
2022-07-04gnu: Add trytond-stock-package-shipping-dpd....Hartmut Goebel
2022-07-04gnu: Add trytond-google-maps....Hartmut Goebel
2022-07-04gnu: Add trytond-gis....Hartmut Goebel