;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012, 2013, 2017 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gperf) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public gperf (package (name "gperf") (version "3.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "1qispg6i508rq8pkajh26cznwimbnj06wq9sd85vg95v8nwld1aq")))) (build-system gnu-build-system) (arguments '(#:parallel-tests? #f)) (home-page "https://www.gnu.org/software/gperf/") (synopsis "Perfect hash function generator") (description "gperf is a perfect hash function generator. For a given list of strings, it produces a hash function and hash table in C or C++ code. That the hash function is perfect means that no collisions can exist and that look-ups can be made by single string comparisons.") (license gpl3+))) (define-public gperf-3.0 ;; This older version would use 'unsigned int' in its generated lookup ;; functions whereas 3.1 uses 'size_t', which causes breakage such as ;; . (package (inherit gperf) (version "3.0.4") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gperf/gperf-" version ".tar.gz")) (sha256 (base32 "0gnnm8iqcl52m8iha3sxrzrl9mcyhg7lfrhhqgdn4zj00ji14wbn")))))) e53c72f04e825f33269258c5ebbc33b70131'>ftp.scm
AgeCommit message (Expand)Author
2023-02-19gnu: Use HTTPS package home pages wherever possible.Tobias Geerinckx-Rice
2022-12-02gnu: wxWidgets: Update to 3.2.1.Marius Bakke
2022-11-27gnu: filezilla: Update to 3.62.2.Marius Bakke
2022-11-27gnu: libfilezilla: Update to 0.39.2.Marius Bakke
2022-06-19gnu: filezilla: Update to 3.60.1.Tobias Geerinckx-Rice
2022-06-19gnu: libfilezilla: Update to 0.37.2.Tobias Geerinckx-Rice
2022-06-05gnu: ncftp: Build reproducibly.Vagrant Cascadian
2022-02-15gnu: filezilla: Update to 3.58.0.Jai Vetrivelan
2022-02-15gnu: libfilezilla: Update to 0.36.0.Jai Vetrivelan
2021-12-17gnu: filezilla: Remove input labels.Tobias Geerinckx-Rice
2021-12-17gnu: filezilla: Update to 3.57.0.Tobias Geerinckx-Rice
2021-12-17gnu: libfilezilla: Remove input labels.Tobias Geerinckx-Rice
2021-12-17gnu: libfilezilla: Update to 0.35.0.Tobias Geerinckx-Rice
2021-12-17gnu: Remove unneeded uses of custom GCC versions.Marius Bakke
2021-12-13gnu: Further simplify package inputs.Ludovic Courtès
2021-12-13gnu: Simplify package inputs.Ludovic Courtès