;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2016 Efraim Flashner ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gkrellm) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public gkrellm (package (name "gkrellm") (version "2.3.11") (source (origin (method url-fetch) (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-" version ".tar.bz2")) (sha256 (base32 "01lccz4fga40isv09j8rjgr0qy10rff9vj042n6gi6gdv4z69q0y")))) (build-system gnu-build-system) (inputs `(("gettext" ,gettext-minimal) ("gtk+" ,gtk+-2) ("libice" ,libice) ("libsm" ,libsm))) (native-inputs `(("pkg-config" ,pkg-config))) (arguments `(#:tests? #f ; there is no check target #:phases (modify-phases %standard-phases (delete 'configure)) ; no configure script #:make-flags (let ((out (assoc-ref %outputs "out"))) (list (string-append "INSTALLROOT=" out) "CC=gcc")))) (home-page "http://gkrellm.srcbox.net/") (synopsis "System monitors") (description "GKrellM is a single process stack of system monitors which supports applying themes to match its appearance to your window manager, Gtk, or any other theme.") (license license:gpl3+))) 'content'>
AgeCommit message (Expand)Author
2020-06-09activation: Fix function call for system activation...Royce Strange
2020-06-08system: Support activation service for the Hurd....Jan (janneke) Nieuwenhuizen
2020-01-06activation: Check whether /proc/sys/kernel/modprobe exists....kanichos@yandex.ru
2020-01-02activation: Keep going when failing to create one of the setuid programs....Ludovic Courtès
2019-06-05activation: Lock /etc/.pwd.lock before accessing databases....Ludovic Courtès
2019-03-08activation: Shared system home directories are now 555 and root-owned....Ludovic Courtès
2019-03-07activation: Build account databases with (gnu build accounts)....Ludovic Courtès
2019-03-07activation: Operate on <user-account> and <user-group> records....Ludovic Courtès
2019-03-04activation: Make home directories #o700 by default....Ludovic Courtès
2018-11-18activation: Aways pass '-d HOME' to 'useradd'....Ludovic Courtès
2018-03-27activation: Pass '-d HOME' to 'usermod'....Ludovic Courtès
2017-10-08activation: Do not create setuid binaries in the store [security fix]....Ludovic Courtès
2017-08-03activation: Make sure /etc exists....Ludovic Courtès