;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2016 Efraim Flashner ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages gkrellm) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gettext) #:use-module (gnu packages gtk) #:use-module (gnu packages pkg-config) #:use-module (gnu packages xorg)) (define-public gkrellm (package (name "gkrellm") (version "2.3.11") (source (origin (method url-fetch) (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-" version ".tar.bz2")) (sha256 (base32 "01lccz4fga40isv09j8rjgr0qy10rff9vj042n6gi6gdv4z69q0y")))) (build-system gnu-build-system) (inputs `(("gettext" ,gettext-minimal) ("gtk+" ,gtk+-2) ("libice" ,libice) ("libsm" ,libsm))) (native-inputs (list pkg-config)) (arguments `(#:tests? #f ; there is no check target #:phases (modify-phases %standard-phases (delete 'configure)) ; no configure script #:make-flags (let ((out (assoc-ref %outputs "out"))) (list (string-append "INSTALLROOT=" out) "CC=gcc")))) (home-page "http://gkrellm.srcbox.net/") (synopsis "System monitors") (description "GKrellM is a single process stack of system monitors which supports applying themes to match its appearance to your window manager, Gtk, or any other theme.") (license license:gpl3+))) b'>linux-initrd.scm
AgeCommit message (Expand)Author
2020-11-26mapped-devices: Add 'lvm-device-mapping'....Mikhail Tsykalov
2020-11-26mapped-devices: Allow target to be list of strings....Mikhail Tsykalov
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-05-16linux-initrd: Silence Guile warnings....Ludovic Courtès
2020-05-05Merge branch 'master' into core-updatesMarius Bakke
2020-05-03linux-initrd: Provide fsck for F2FS....Danny Milosavljevic
2020-05-02Merge branch 'master' into core-updatesMarius Bakke
2020-05-02linux-initrd: Add initial support for F2FS....raingloom
2020-05-01gnu: linux-initrd: Use Guile 3.0....Marius Bakke
2020-01-03linux-initrd: Add support for JFS....Tobias Geerinckx-Rice
2019-09-04linux-initrd: Use native gzip....Mathieu Othacehe
2019-08-16linux-modules: Define and use a module name database....Ludovic Courtès