;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014, 2015, 2018 Ludovic Courtès ;;; Copyright © 2015 Andreas Enge ;;; Copyright © 2015 Mark H Weaver ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice ;;; Copyright © 2017 Rene Saavedra ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public L
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-web.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index c776191c74..90d7323e21 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -523,28 +523,28 @@ Manager,NTLM}/Negotiate authentication over HTTP.")
(license license:expat)))
(define-public go-github-com-ccding-go-stun
- (package
- (name "go-github-com-ccding-go-stun")
- (version "0.1.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/ccding/go-stun")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0wjhckyg42kp04njhj7gni84cyk0s7m17n13kqf6r7mjzx8a83pw"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/ccding/go-stun"))
- (home-page "https://github.com/ccding/go-stun")
- (synopsis "STUN client implementation")
- (description
- "Go-stun is a go implementation of the STUN client (RFC 3489
+ (package
+ (name "go-github-com-ccding-go-stun")
+ (version "0.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ccding/go-stun")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wjhckyg42kp04njhj7gni84cyk0s7m17n13kqf6r7mjzx8a83pw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ccding/go-stun"))
+ (home-page "https://github.com/ccding/go-stun")
+ (synopsis "STUN client implementation")
+ (description
+ "Go-stun is a go implementation of the STUN client (RFC 3489
and RFC 5389).")
- (license license:asl2.0)))
+ (license license:asl2.0)))
(define-public go-github-com-cenkalti-backoff-v4
(package
(synopsis "Cross-platform C++ library used by Filezilla client") (description "This package provides some basic functionality to build high-performing, platform-independent programs. Some of the highlights include: @itemize @item A type-safe, multi-threaded event system that's simple to use yet efficient. @item Timers for periodic events. @item A @code{datetime} class that not only tracks timestamp but also their accuracy, which simplifies dealing with timestamps originating from different sources. @item Simple process handling for spawning child processes with redirected input and output. @end itemize\n") (license gpl2+))) (define-public filezilla (package (name "filezilla") (version "3.50.0") (source (origin (method url-fetch) (uri (string-append "https://download.filezilla-project.org/client/" "FileZilla_" version "_src.tar.bz2")) (sha256 (base32 "042w2f5cf8g9cr7d3m6294ygx7jggcria9502jnql855khk8gnz0")))) (build-system gnu-build-system) (arguments ;; Don't let filezilla phone home to check for updates. '(#:configure-flags '("--disable-autoupdatecheck"))) (native-inputs `(("cppunit" ,cppunit) ("gettext" ,gettext-minimal) ("pkg-config" ,pkg-config) ("xdg-utils" ,xdg-utils))) (inputs `(("dbus" ,dbus) ("gnutls" ,gnutls) ("gtk+" ,gtk+) ("libfilezilla" ,libfilezilla) ("libidn" ,libidn) ("nettle" ,nettle) ("pugixml" ,pugixml) ("sqlite" ,sqlite) ("wxwidgets" ,wxwidgets))) (home-page "https://filezilla-project.org") (synopsis "Full-featured graphical FTP/FTPS/SFTP client") (description "Filezilla client supports FTP, FTP over SSL/TLS (FTPS), SSH File Transfer Protocol (SFTP), HTTP/1.1, SOCKS5, FTP-Proxy, IPv6 and others features such as bookmarks, drag and drop, filename filters, directory comparison and more.") (license gpl2+) (properties '((upstream-name . "FileZilla"))))) (define-public vsftpd (package (name "vsftpd") (version "3.0.3") (source (origin (method url-fetch) (uri (string-append "https://security.appspot.com/downloads/" name "-" version ".tar.gz")) (sha256 (base32 "1xsyjn68k3fgm2incpb3lz2nikffl9by2safp994i272wvv2nkcx")))) (build-system gnu-build-system) (arguments `(#:make-flags '("LDFLAGS=-lcrypt") #:tests? #f ; No tests exist. #:phases (modify-phases %standard-phases (add-after 'unpack 'patch-installation-directory (lambda* (#:key outputs #:allow-other-keys) (substitute* "Makefile" (("/usr") (assoc-ref outputs "out"))) #t)) (add-before 'install 'mkdir (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (mkdir-p out) (mkdir (string-append out "/sbin")) (mkdir (string-append out "/man")) (mkdir (string-append out "/man/man5")) (mkdir (string-append out "/man/man8")) #t))) (delete 'configure)))) (synopsis "vsftpd FTP daemon") (description "@command{vsftpd} is a daemon that listens on a TCP socket for clients and gives them access to local files via File Transfer Protocol.") (home-page "https://security.appspot.com/vsftpd.html") (license gpl2)))