;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ftp) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages ncurses) #:use-module (gnu packages readline) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gnutls) #:use-module (gnu packages compression)) (define-public lftp (package (name "lftp") (version "4.4.15") (source (origin (method url-fetch) (uri (string-append "http://lftp.yar.ru/ftp/lftp-" version ".tar.xz")) (sha256 (base32 "0s38vc2ij869dwx3i1c7sk96mqv0hknf3cqf86av59rqnix0px3m")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("zlib" ,zlib) ("readline" ,readline) ("gnutls" ,gnutls))) (home-page "http://lftp.yar.ru/") (synopsis "Command-line file transfer program") (description "LFTP is a sophisticated FTP/HTTP client, and a file transfer program supporting a number of network protocols. Like Bash, it has job control and uses the Readline library for input. It has bookmarks, a built-in mirror command, and can transfer several files in parallel. It was designed with reliability in mind.") (license gpl3+))) guix/log/gnu?id=24455759cdc7e03c655d13090b627eee489d4661'>gnu/packages/cluster.scm
AgeCommit message (Expand)Author
2023-04-23gnu: libraft: Disable test that requires connectivity....Brian Cully
2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner
2022-11-23gnu: drbd-utils: Fix corrupted man page....Marius Bakke
2022-11-03gnu: drbd-utils: Update to 9.22.0....Marius Bakke
2022-06-20gnu: drbd-utils: Generate manual pages....Marius Bakke
2022-06-20gnu: drbd-utils: Use new style....Marius Bakke
2022-06-20gnu: drbd-utils: Update to 9.21.2....Marius Bakke
2022-06-20gnu: drbd-utils: Add release-monitoring-url....Marius Bakke
2021-12-13gnu: Simplify package inputs....Ludovic Courtès
2021-12-05gnu: drbd-utils: Update to 9.19.1....Marius Bakke
2021-10-11gnu: drbd-utils: Update to 9.19.0....Marius Bakke
2021-09-28gnu: libdqlite: Update to 1.9.0....Andrew Whatson
2021-09-28gnu: libraft: Update to 0.11.2....Andrew Whatson