;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Ludovic Courtès ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ftp) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages ncurses) #:use-module (gnu packages readline) #:use-module (gnu packages pkg-config) #:use-module (gnu packages gnutls) #:use-module (gnu packages compression)) (define-public lftp (package (name "lftp") (version "4.4.15") (source (origin (method url-fetch) (uri (string-append "http://lftp.yar.ru/ftp/lftp-" version ".tar.xz")) (sha256 (base32 "0s38vc2ij869dwx3i1c7sk96mqv0hknf3cqf86av59rqnix0px3m")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("zlib" ,zlib) ("readline" ,readline) ("gnutls" ,gnutls))) (home-page "http://lftp.yar.ru/") (synopsis "Command-line file transfer program") (description "LFTP is a sophisticated FTP/HTTP client, and a file transfer program supporting a number of network protocols. Like Bash, it has job control and uses the Readline library for input. It has bookmarks, a built-in mirror command, and can transfer several files in parallel. It was designed with reliability in mind.") (license gpl3+))) ontent'>
AgeCommit message (Expand)Author
2023-10-22teams: Adjust shebang to use 'guix repl'.Maxim Cournoyer
2023-04-24Add mumi config.Arun Isaac
2
2021-12-1?id=4eaf90470f466b3fdab87f6961cb18bb348d433f'>etc: Add teams.scm.Ricardo Wurmus
2022-06-05gitignore: Add .DS_Store.Pavel Shlyak
2021-10-16.gitignore: Ignore more autotools directories.Sarah Morgensen
2021-10-16.gitignore: Ignore more temporary test directories.Sarah Morgensen
2021-09-20etc: Add systemd files for running ‘guix gc’ periodicallyThiago Jung Bauermann
2021-05-10.gitignore: Ignore .mo files.Maxim Cournoyer
2021-05-05.gitignore: Ignore .tarball-ignore.Maxim Cournoyer
2021-04-23.gitignore: Ignore release artifacts.Maxim Cournoyer
2021-04-23.gitignore: Ignore generated .pot files.Maxim Cournoyer
2020-10-20gitignore: Ignore generated guile binary and intermediate products.Julien Lepiller
2020-09-17guix-install.sh: Support OpenRC.Morgan Smith
2020-07-17gitignore: Don't ignore daemon source code.Jakub Kądziołka
2020-06-28.gitignore: Ignore 'etc/committer.scm'.Brice Waegeneire