;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Ludovic Courtès ;;; Copyright © 2015, 2016, 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages freeipmi) #:use-module (guix packages) #:use-module (guix licenses) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages gnupg)) (define-public freeipmi (package (name "freeipmi") (version "1.6.1") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/freeipmi/freeipmi-" version ".tar.gz")) (sha256 (base32 "0jdm1nwsnkj0nzjmcqprmjk25449mhjj25khwzpq3mpjw440wmd2")))) (build-system gnu-build-system) (inputs `(("libgcrypt" ,libgcrypt))) (home-page "https://www.gnu.org/software/freeipmi/") (synopsis "Platform management, including sensor and power monitoring") (description "GNU FreeIPMI is a collection of in-band and out-of-band IPMI software in accordance with the IPMI v1.5/2.0 specification. These programs provide a set of interfaces for platform management. Common functionality includes sensor monitoring, system event monitoring, power control and serial-over-LAN.") (license gpl3+))) log/?id=5ecfa6f5659bebefabbc6ba3322faf3936358ed5'>root/release.nix
AgeCommit message (Expand)Author
2013-05-12release.nix: Revert back to before unchroot experiments....Ludovic Courtès
2013-03-18release.nix: Hack to unchroot more stuff....Ludovic Courtès
2013-03-18release.nix: Adjust to current Nixpkgs....Ludovic Courtès
2013-03-02release.nix: Reduce the number of dependencies....Ludovic Courtès
2013-03-02release.nix: Unchroot recursively....Ludovic Courtès
2013-03-02release.nix: Build outside of a chroot....Ludovic Courtès
2013-01-06Merge branch 'master' into core-updates...Ludovic Courtès
2013-01-06Update license headers....Ludovic Courtès
2013-01-02release.nix: Update to new bootstrap Guile tarball....Ludovic Courtès
2012-12-14release.nix: Remove trailing "/nix" from localstatedir....Ludovic Courtès
2012-12-13release.nix: tarball: Fix typo....Ludovic Courtès
2012-12-13release.nix: Add `build_disable_daemon'....Ludovic Courtès
2012-12-13release.nix: build: Allow builds within a chroot....Ludovic Courtès
2012-12-13release.nix: Build the daemon....Ludovic Courtès
2012-11-04release.nix: Pass `--with-libgcrypt-prefix' in the `tarball' job....Ludovic Courtès
2012-11-03build: Clearly mark Nixpkgs as optional....Ludovic Courtès
2012-10-31release.nix: Use `--no-substitutes' in `distro.hello'....Ludovic Courtès
2012-10-28release.nix: Change `distro.hello' to produce something....Ludovic Courtès
2012-10-27release.nix: Add a `distro.hello' job....Ludovic Courtès