;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 Nikita ;;; Copyright © 2016 Sou Bunnbu ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages forth) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages m4)) (define-public gforth (package (name "gforth") (version "0.7.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gforth/gforth-" version ".tar.gz")) (sha256 (base32 "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig")))) (build-system gnu-build-system) (arguments '(#:parallel-build? #f ; XXX: parallel build fails #:phases (modify-phases %standard-phases (add-after 'install 'install-gforth.el (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (emacs-sitedir (string-append out "/share/emacs/site-lisp"))) ;; TODO: compile and autoload it. (install-file "gforth.el" emacs-sitedir) #t)))))) (native-inputs (list m4)) (synopsis "Forth interpreter") (description "Gforth is a fast and portable implementation of the ANSI Forth language. It includes an editing mode for Emacs and an interpreter featuring completion and history. A generic virtual machine environment, vmgen, is also included.") (home-page "https://www.gnu.org/software/gforth/") (license license:gpl3+))) ss='content'>
AgeCommit message (Expand)Author
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-11-21gnu: python-nautilus: Remove package.John Kehayias
2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe
2021-10-11gnu: owncloud-client: Fix sysconfdir pathDaniel Meißner
2021-10-11gnu: owncloud-client: Update to 2.9.0.5150.Liliana Marie Prikler
2021-07-24gnu: Use 'search-input-directory' when looking for C/C++ library headers.Ludovic Courtès
2021-06-14gnu: Rename qtbase to qtbase-5.Maxim Cournoyer
2021-03-10gnu: Add nextcloud-client.Raghav Gururajan
2021-03-02gnu: usync: Patch shebang.Ludovic Courtès
2021-03-02gnu: Add usync.Stefan Reichör
2021-02-28gnu: owncloud-client: Update to 2.7.6.3261.Léo Le Bouter
2021-02-07gnu: owncloud-client: Update to 2.7.5.3180.Julien Lepiller
2020-08-17gnu: rclone: Update to 1.52.3.Nicolas Goaziou
2020-08-13gnu: megatools: Install bash completion.Efraim Flashner
2020-08-13gnu: megatools: Update to 1.10.3.Efraim Flashner
2020-07-12gnu: Remove ".git" from "https://github/…/….git".Ludovic Courtès
2020-06-30gnu: rclone: Update to 1.52.2.Tobias Geerinckx-Rice
2020-06-14gnu: rclone: Update to 1.52.1.Tobias Geerinckx-Rice
2020-06-02gnu: rclone: Update to 1.52.0.Nicolas Goaziou