;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2016 ng0 ;;; Copyright © 2016 Sou Bunnbu ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages forth) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages m4)) (define-public gforth (package (name "gforth") (version "0.7.3") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/gforth/gforth-" version ".tar.gz")) (sha256 (base32 "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig")))) (build-system gnu-build-system) (arguments '(#:parallel-build? #f ; XXX: parallel build fails #:phases (modify-phases %standard-phases (add-after 'install 'install-gforth.el (lambda* (#:key outputs #:allow-other-keys) (let* ((out (assoc-ref outputs "out")) (emacs-sitedir (string-append out "/share/emacs/site-lisp"))) ;; TODO: compile and autoload it. (install-file "gforth.el" emacs-sitedir) #t)))))) (native-inputs `(("m4" ,m4))) (synopsis "Forth interpreter") (description "Gforth is a fast and portable implementation of the ANSI Forth language. It includes an editing mode for Emacs and an interpreter featuring completion and history. A generic virtual machine environment, vmgen, is also included.") (home-page "https://www.gnu.org/software/gforth/") (license license:gpl3+))) fe731624eab56edb396909e72e727e&showmsg=1'>packages/parallel.scm
AgeCommit message (Collapse)Author
2019-06-18gnu: Add python-slurm-magic.Ludovic Courtès
* gnu/packages/parallel.scm (python-slurm-magic): New variable.
2019-05-23gnu: parallel: Update to 20190522.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20190522.
2019-04-22gnu: parallel: Update to 20190422.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20190422.
2019-04-16gnu: slurm: Configure with a "standard" syslogdir.Ludovic Courtès
Until now, we were using syslogdir=$prefix/etc, which did not exist. Thus, commands would always fail like this: $ guix environment --ad-hoc slurm --pure -- squeue -u $USER squeue: error: s_p_parse_file: unable to status file /gnu/store/…-slurm-17.11.3/etc/slurm.conf: No such file or directory, retrying in 1sec up to 60sec * gnu/packages/parallel.scm (slurm)[arguments]: Pass --sysconfdir.
2019-03-22gnu: parallel: Update to 20190322.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20190322.
2019-02-24gnu: parallel: Update to 20190222.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20190222.
2019-02-12gnu: parallel: Update to 20190122.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20190122.
2018-12-24gnu: parallel: Update to 20181222.Rutger Helling
* gnu/packages/parallel.scm (parallel): Update to 20181222.
2018-11-28gnu: parallel: Update to 20181122.Efraim Flashner
* gnu/packages/parallel.scm (parallel): Update to 20181122.
2018-10-27gnu: parallel: Update to 20181022.Tobias Geerinckx-Rice
* gnu/packages/parallel.scm (parallel): Update to 20181022.