;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014, 2015 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages file) #:use-module (gnu packages) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public file (package (name "file") (version "5.22") (source (origin (method url-fetch) (uri (string-append "ftp://ftp.astron.com/pub/file/file-" version ".tar.gz")) (sha256 (base32 "02zw14hw3gqlw91w2f2snbirvyrp7r83irvnnkjcb25q9kjaiqy4")))) (build-system gnu-build-system) ;; When cross-compiling, this package depends upon a native install of ;; itself. (self-native-input? #t) (synopsis "File type guesser") (description "The file command is a file type guesser, a command-line tool that tells you in words what kind of data a file contains. It does not rely on filename extensions to tell you the type of a file, but looks at the actual contents of the file.") (license bsd-2) (home-page "http://www.darwinsys.com/file/"))) type='search' size='10' name='q' value=''/>
AgeCommit message (Expand)Author
2021-06-14gnu: Rename qtbase to qtbase-5....Maxim Cournoyer
2021-05-23gnu: nvc: Update to 1.5.1....Tobias Geerinckx-Rice
2021-05-07gnu: gtkwave: Update to 3.3.109....Tobias Geerinckx-Rice
2021-03-06gnu: verilator: Update to 4.110....Tobias Geerinckx-Rice
2021-01-28gnu: Add Verilator....Andrew Miloradovsky
2021-01-28gnu: Add systemc....Andrew Miloradovsky
2021-01-07gnu: gtkwave: Update to 3.3.108....Tobias Geerinckx-Rice
2020-12-30gnu: Add python-migen....Vinicius Monego
2020-12-17gnu: Add nvc....Danny Milosavljevic
2020-12-16gnu: Add python-myhdl....Danny Milosavljevic