;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014, 2015 Mark H Weaver ;;; Copyright © 2016, 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages file) #:use-module (gnu packages) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public file (package (replacement file/fixed) (name "file") (version "5.30") (source (origin (method url-fetch) (uri (string-append "ftp://ftp.astron.com/pub/file/file-" version ".tar.gz")) (sha256 (base32 "057jpcyy8ws7q4s4sm8r1rxb8xycdbng2z4y9i98f094wlr28k39")))) (build-system gnu-build-system) ;; When cross-compiling, this package depends upon a native install of ;; itself. (self-native-input? #t) (synopsis "File type guesser") (description "The file command is a file type guesser, a command-line tool that tells you in words what kind of data a file contains. It does not rely on filename extensions to tell you the type of a file, but looks at the actual contents of the file.") (license bsd-2) (home-page "http://www.darwinsys.com/file/"))) (define file/fixed (package (inherit file) (source (origin (inherit (package-source file)) (patches (search-patches "file-CVE-2017-1000249.patch")))))) ref='/guix/log/gnu/packages?id=b8b1e4d9a2a976c4cd9933bb6a7451340f17e9ec'>packages/gimp.scm
AgeCommit message (Expand)Author
2019-04-11gnu: gimp: Fix typo in description....Tobias Geerinckx-Rice
2019-04-08gnu: GIMP: Update to 2.10.10....Leo Famulari
2019-03-05gnu: gegl: Update to 0.4.14....Tobias Geerinckx-Rice
2019-02-19gnu: gimp: Update to 2.10.8....Tobias Geerinckx-Rice
2019-02-19gnu: gegl: Don't use NAME in source URI....Tobias Geerinckx-Rice
2019-02-19gnu: gegl: Update to 0.4.12....Tobias Geerinckx-Rice
2019-02-19gnu: babl: Update to 0.1.62....Tobias Geerinckx-Rice
2018-10-08gnu: Add gimp-resynthesizer....Thorsten Wilms
2018-08-20gnu: gimp: Report bugs to Guix....Tobias Geerinckx-Rice
2018-08-20gnu: gimp: Update to 2.10.6....Tobias Geerinckx-Rice
2018-08-20gnu: gegl: Update to 0.4.8....Tobias Geerinckx-Rice
2018-08-20gnu: babl: Update to 0.1.56....Tobias Geerinckx-Rice
2018-08-17gnu: Use HTTPS for gtk.org....Tobias Geerinckx-Rice