;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014, 2015 Mark H Weaver ;;; Copyright © 2016, 2017 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages file) #:use-module (gnu packages) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public file (package (replacement file/fixed) (name "file") (version "5.30") (source (origin (method url-fetch) (uri (string-append "ftp://ftp.astron.com/pub/file/file-" version ".tar.gz")) (sha256 (base32 "057jpcyy8ws7q4s4sm8r1rxb8xycdbng2z4y9i98f094wlr28k39")))) (build-system gnu-build-system) ;; When cross-compiling, this package depends upon a native install of ;; itself. (self-native-input? #t) (synopsis "File type guesser") (description "The file command is a file type guesser, a command-line tool that tells you in words what kind of data a file contains. It does not rely on filename extensions to tell you the type of a file, but looks at the actual contents of the file.") (license bsd-2) (home-page "http://www.darwinsys.com/file/"))) (define file/fixed (package (inherit file) (source (origin (inherit (package-source file)) (patches (search-patches "file-CVE-2017-1000249.patch")))))) /etc/completion?id=e2a04cb31a963b8f1bfa80a50c8bf4e257fce8f8'>completion/bash
AgeCommit message (Expand)Author
2023-12-10bash completion: Complete ‘guix style -f’ with files....Tobias Geerinckx-Rice
2022-05-29bash completion: Fix & unify option parsing....Tobias Geerinckx-Rice
2022-01-17bash completion: Complete "guix home" sub-commands....Ludovic Courtès
2022-01-16bash completion: Fix options completion....Fulbert
2021-12-08bash completion: Complete ‘guix shell -f’....Tobias Geerinckx-Rice
2021-10-31bash completion: Complete top-level options....Tobias Geerinckx-Rice
2021-10-31bash completion: Don't hard-code "guix" binary name....Tobias Geerinckx-Rice
2021-10-25Add 'guix shell'....Ludovic Courtès
2021-10-03bash completion: Fix ‘system’ & ‘container’ subcommands....Tobias Geerinckx-Rice
2021-10-03bash completion: Complete ‘guix size’ file names....Tobias Geerinckx-Rice
2021-10-03bash completion: Complete ‘guix build’ file names....Tobias Geerinckx-Rice
2021-10-03bash completion: Complete ‘guix weather’ packages....Tobias Geerinckx-Rice
2021-10-03bash completion: Append to $COMPREPLY where possible....Tobias Geerinckx-Rice
2021-10-03bash completion: Consolidate similar $command ‘if’ branches....Tobias Geerinckx-Rice
2021-06-16bash_completion: Complete options for ‘guix environment’....Tobias Geerinckx-Rice
2021-06-16bash completion: Complete options for the right command....Tobias Geerinckx-Rice
2021-06-16bash completion: Really support subcommands....Tobias Geerinckx-Rice