;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Andreas Enge ;;; Copyright © 2014, 2015 Mark H Weaver ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages file) #:use-module (gnu packages) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public file (package (name "file") (version "5.22") (source (origin (method url-fetch) (uri (string-append "ftp://ftp.astron.com/pub/file/file-" version ".tar.gz")) (sha256 (base32 "02zw14hw3gqlw91w2f2snbirvyrp7r83irvnnkjcb25q9kjaiqy4")))) (build-system gnu-build-system) ;; When cross-compiling, this package depends upon a native install of ;; itself. (self-native-input? #t) (synopsis "File type guesser") (description "The file command is a file type guesser, a command-line tool that tells you in words what kind of data a file contains. It does not rely on filename extensions to tell you the type of a file, but looks at the actual contents of the file.") (license bsd-2) (home-page "http://www.darwinsys.com/file/"))) type='search' size='10' name='q' value=''/>
x?' predicate....
AgeCommit message (Expand)Author
2019-11-13services: dbus: Simplify 'dbus-uuidgen' invocation....Ludovic Courtès
2019-11-13services: dbus: Log to syslog....Ludovic Courtès
2019-11-13services: dbus: Add description....Ludovic Courtès
2019-11-02services: dbus: Remove non-existent directories from 'system-local.conf'....Ludovic Courtès
2019-11-02services: dbus: Include each service's "share/dbus-1/system.d"....Ludovic Courtès
Maxime Devos
2021-02-03utils: Add string distance....zimoun
2021-02-01utils: Add 'version-unique-prefix'....Ludovic Courtès
2021-01-13utils: Support zstd compression via Guile-zstd....Ludovic Courtès
2021-01-13utils: Remove 'compressed-output-port'....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2019-06-20utils: canonical-newline-port: Fix handling of carriage return at buffer end....Robert Vollmert
2019-05-27utils: Support compression and decompression with lzip....Ludovic Courtès
2019-05-27utils: Test 'compressed-port' and 'decompressed-port' for both gzip and xz....Ludovic Courtès
2018-05-13utils: Add 'version-prefix?'....Ludovic Courtès
2018-05-10union: Add 'relative-file-name'....Ludovic Courtès
2017-03-16utils: Move base16 procedures to (guix base16)....Ludovic Courtès