;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Steve Sprang ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages figlet) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public figlet (package (name "figlet") (version "2.2.5") (source (origin (method url-fetch) (uri (string-append "ftp://ftp.figlet.org/pub/figlet/program" "/unix/figlet-" version ".tar.gz")) (sha256 (base32 "0za1ax15x7myjl8jz271ybly8ln9kb9zhm1gf6rdlxzhs07w925z")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (delete 'configure)) #:make-flags (list (string-append "prefix=" %output)))) (home-page "http://www.figlet.org/") (synopsis "Make large letterforms out of ordinary screen characters") (description "FIGlet is a program for making large ASCII art letterforms out of ordinary screen characters.") (license license:bsd-3))) ter
AgeCommit message (Expand)Author
2020-12-27maint: Remove unused '--with-nix-prefix' configure option....Ludovic Courtès
2020-12-19maint: Require Guile >= 2.2.6....Ludovic Courtès
2020-12-11maint: Avoid macros obsolete in Autoconf 2.70....Ludovic Courtès
2020-11-29Make "guile-avahi" dependency optional....Mathieu Othacehe
2020-11-29Add Avahi support....Mathieu Othacehe
2020-10-22git: Require Guile-Git 0.3.0 or later....Ludovic Courtès
2020-10-05build: Use a 'guile' executable that doesn't warn about locales....Ludovic Courtès
2020-08-29build: Remove references to the 'nix-hash' program....Ludovic Courtès
2020-08-29build: Remove check for Guile 2.2.1 bug....Ludovic Courtès
2020-08-24Use "guile-zlib" and "guile-lzlib" instead of (guix config)....Mathieu Othacehe
2020-06-16etc: Add committer script....Ricardo Wurmus
2020-05-28maint: Check whether Guile-Gcrypt is recent enough....Ludovic Courtès
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-04-23build: Don't build man pages when cross-compiling....Ludovic Courtès
2020-03-11build: Require Guile 2.2.3 or later....Ludovic Courtès
2020-01-17build: Allow builds with Guile 3.0....Ludovic Courtès
2019-11-09build: Warn about etc/indent-code.el when Emacs is absent....zimoun