;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013 Nikita Karetnikov ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages fdisk) #:use-module ((guix licenses) #:select (gpl3+)) #:use-module (gnu packages gettext) #:use-module (gnu packages guile) #:use-module (gnu packages linux) #:use-module (gnu packages parted) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public fdisk (package (name "fdisk") (version "2.0.0a") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/fdisk/gnufdisk-" version ".tar.gz")) (sha256 (base32 "04nd7civ561x2lwcmxhsqbprml3178jfc58fy1v7hzqg5k4nbhy3")))) (build-system gnu-build-system) (inputs `(("gettext" ,gnu-gettext) ("guile" ,guile-1.8) ("util-linux" ,util-linux) ("parted" ,parted))) (home-page "https://www.gnu.org/software/fdisk/") (synopsis "Low-level disk partitioning and formatting") (description "GNU fdisk provides a GNU version of the common disk partitioning tool fdisk. fdisk is used for the creation and manipulation of disk partition tables, and it understands a variety of different formats.") (license gpl3+)))
AgeCommit message (Expand)Author
2022-05-26cuirass: Create just as many threads as needed.Ludovic Courtès
2022-05-26cuirass: Fork inferior processes before creating threads.Ludovic Courtès
2022-05-20cuirass: Close each inferior upon completion.Ludovic Courtès
2021-03-10ci: Remove hydra support.Mathieu Othacehe
2020-10-04cuirass: Add hurd-manifest.Jan (janneke) Nieuwenhuizen
2018-04-08cuirass: Add job specs for the modular Guix.Ludovic Courtès
2018-04-08cuirass: Factorize hydra-to-cuirass CI job translation.Ludovic Courtès
2018-01-15cuirass: Properly convert list of <license> objects.Ludovic Courtès
2017-09-27cuirass: Add gnu-system build spec.Jan Nieuwenhuizen