;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2019 Danny Milosavljevic ;;; Copyright © 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages efi) #:use-module (gnu packages autotools) #:use-module (gnu packages bash) #:use-module (gnu packages linux) #:use-module (gnu p
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:06:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:07 +0200
commita8a990ff0e8855218a88854d40129173d0ca48f1 (patch)
tree1240448c5f00f227c0221a28fd72e54f7f0b814e /.dir-locals.el
parent65a17e01f493f955880abf960e8eae9da69713fe (diff)
downloadguix-a8a990ff0e8855218a88854d40129173d0ca48f1.tar.gz
guix-a8a990ff0e8855218a88854d40129173d0ca48f1.zip
gnu: Add texlive-euler.
* gnu/packages/tex.scm (texlive-euler): New variable.
Diffstat (limited to '.dir-locals.el')
0 files changed, 0 insertions, 0 deletions
) (delete 'configure)))) (native-inputs `(("help2man" ,help2man) ("perl" ,perl) ("perl-file-slurp" ,perl-file-slurp) ("sbsigntools" ,sbsigntools))) (inputs `(("gnu-efi" ,gnu-efi) ("openssl" ,openssl))) (synopsis "EFI tools (key management, variable management)") (description "This package provides EFI tools for EFI key management and EFI variable management.") (home-page "https://blog.hansenpartnership.com/efitools-1-4-with-linux-key-manipulation-utilities-released/") ;; Programs are under GPL 2. ;; Library routines (in lib/) are under LGPL 2.1. ;; Compiling/linking/using OpenSSL is permitted. (license (list license:gpl2 license:lgpl2.1)))) (define-public efilinux (package (name "efilinux") (version "1.1") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/mfleming/efilinux.git") (commit (string-append "efilinux-" version)))) (file-name (git-file-name name version)) (sha256 (base32 "0b4nxzr3wl5v4b52r79iw1arfgasz26xb38r2blw9v2qz2s1q9w2")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" ,@(match (%current-system) ("aarch64-linux" '("ARCH=aarch64")) ("armhf-linux" '("ARCH=arm")) (_ '())) (string-append "INCDIR=" (assoc-ref %build-inputs "gnu-efi") "/include") (string-append "LIBDIR=" (assoc-ref %build-inputs "gnu-efi") "/lib")) #:tests? #f ; No tests exist. #:phases (modify-phases %standard-phases (delete 'configure) (replace 'install (lambda* (#:key outputs #:allow-other-keys) (install-file "efilinux.efi" (string-append (assoc-ref outputs "out") "/libexec")) #t))))) (inputs `(("gnu-efi" ,gnu-efi))) (synopsis "Minimal Linux loader for UEFI") (description "This package provides a minimal Linux loader as an UEFI program.") (home-page "https://github.com/mfleming/efilinux") (license license:bsd-2)))