;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2013, 2014 Ludovic Courtès ;;; Copyright © 2016, 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ed) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages compression)) (define-public ed (package (name "ed") (version "1.16") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/ed/ed-" version ".tar.lz")) (sha256 (base32 "0b4b1lwizvng9bvpcjnmpj2i80xz9xw2w8nfff27b2h4mca7mh6g")))) (build-system gnu-build-system) (native-inputs `(("lzip" ,lzip))) (arguments '(#:configure-flags '("CC=gcc") #:phases (modify-phases %standard-phases (add-before 'patch-source-shebangs 'patch-test-suite (lambda _ (substitute* "testsuite/check.sh" (("/bin/sh") (which "sh"))) #t))))) (home-page "https://www.gnu.org/software/ed/") (synopsis "Line-oriented text editor") (description "Ed is a line-oriented text editor: rather than offering an overview of a document, ed performs editing one line at a time. It can be executed both interactively and via shell scripts. Its method of command input allows complex tasks to be performed in an automated way. GNU ed offers several extensions over the standard utility.") (license gpl3+))) 1bc77a63f251eb451d2ef8bbb0'>hurd.scm
AgeCommit message (Expand)Author
2017-09-20gnu: Use 'modify-phases' syntax....Kei Kebreau
2017-04-22gnu: Add the Hurd....Manolis Ragkousis
2017-04-22gnu: hurd: Add hurd-source-url procedure....Manolis Ragkousis
2017-03-30gnu: Use HTTPS for almost all gnu.org HOME-PAGEs....Tobias Geerinckx-Rice
2017-03-19gnu: Add GNU Mach....Manolis Ragkousis
2017-02-16gnu: hurd: Add gnumach-source-url procedure....Manolis Ragkousis
2017-01-03gnu: Use hurd-triplet? to check if GNU/Hurd....Manolis Ragkousis
2016-12-19gnu: hurd-headers: Update to 0.9....Manolis Ragkousis
2016-12-19gnu: mig: Update to 1.8....Manolis Ragkousis
2016-12-19gnu: gnumach-headers: Update to 1.8....Manolis Ragkousis