;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2012 Nikita Karetnikov ;;; Copyright © 2013, 2014 Ludovic Courtès ;;; Copyright © 2016, 2019 Efraim Flashner ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages ed) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages compression)) (define-public ed (package (name "ed") (version "1.17") (source (origin (method url-fetch) (uri (string-append "mirror://gnu/ed/ed-" version ".tar.lz")) (sha256 (base32 "0m2yrkfjjraakxr98nsiakqrn351h99n706x9asgmdi57j43kpki")))) (build-system gnu-build-system) (native-inputs (list lzip)) (arguments '(#:configure-flags '("CC=gcc") #:phases (modify-phases %standard-phases (add-before 'patch-source-shebangs 'patch-test-suite (lambda _ (substitute* "testsuite/check.sh" (("/bin/sh") (which "sh"))) #t))))) (home-page "https://www.gnu.org/software/ed/") (synopsis "Line-oriented text editor") (description "Ed is a line-oriented text editor: rather than offering an overview of a document, ed performs editing one line at a time. It can be executed both interactively and via shell scripts. Its method of command input allows complex tasks to be performed in an automated way. GNU ed offers several extensions over the standard utility.") (license gpl3+))) db3e9492'>c.scm
AgeCommit message (Expand)Author
2023-02-16gnu: Remove unneeded module imports....Efraim Flashner
2023-02-11gnu: qbe: Update to 1.1....jgart
2023-01-31gnu: c-intro-and-ref: Update to 0.0.0-1.47e5a23....Hilton Chain
2023-01-22gnu: libhx: Update to 4.9....Tobias Geerinckx-Rice
2023-01-15gnu: mimalloc: Update to 2.0.9....Tobias Geerinckx-Rice
2022-12-11gnu: libhx: Update to 4.8....Tobias Geerinckx-Rice
2022-12-11gnu: byacc: Update to 20221106....Tobias Geerinckx-Rice
2022-11-13gnu: ck: Add support for riscv64-linux....Efraim Flashner
2022-11-13gnu: mimalloc: Update to 2.0.7....Efraim Flashner
2022-11-13gnu: Add c-intro-and-ref....Maxim Cournoyer