;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages dvtm) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (gnu packages ncurses)) (define-public dvtm (package (name "dvtm") (version "0.15") (source (origin (method url-fetch) (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-" version ".tar.gz")) (sha256 (base32 "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (inputs `(("ncurses" ,ncurses))) (synopsis "Tiling window management for the console") (description "dvtm brings the concept of tiling window management, popularized by X11-window managers like dwm, to the console. As a console window manager it tries to make it easy to work with multiple console based programs.") (home-page "https://www.brain-dump.org/projects/dvtm/") ;; "dvtm reuses some code of dwm and is released under the same MIT/X11 ;; license. The terminal emulation part is licensed under the ISC license." ;; source: http://www.brain-dump.org/projects/dvtm/#license (license (list expat isc)))) /xfig.scm
AgeCommit message (Expand)Author
2020-01-22gnu: Replace uses of 'libjpeg' with 'libjpeg-turbo'....Marius Bakke
2018-08-11gnu: xfig: Update to 3.2.7a....Tobias Geerinckx-Rice
2018-06-26gnu: transfig: Return #t from phases....Tobias Geerinckx-Rice
2018-04-16gnu: xfig: Update to 3.2.7....Tobias Geerinckx-Rice
2017-12-12gnu: xfig: Update to 3.2.6a....Tobias Geerinckx-Rice
2017-12-12gnu: xfig, transfig: Update home pages....Tobias Geerinckx-Rice
2017-12-02gnu: xfig: Don't ignore 'xmkmf' exit code....Ludovic Courtès
2017-09-20gnu: Use 'modify-phases' syntax....Kei Kebreau
2017-01-13gnu: xfig: Correct typographic error....John Darrington
2017-01-12gnu: xfig: Remove wrapper and clean up implementation....John Darrington
2017-01-12gnu: xfig: Use modify-phases....John Darrington