;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015, 2016 Leo Famulari ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages dvtm) #:use-module (guix build-system gnu) #:use-module (guix download) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (gnu packages ncurses)) (define-public dvtm (package (name "dvtm") (version "0.15") (source (origin (method url-fetch) (uri (string-append "http://www.brain-dump.org/projects/dvtm/dvtm-" version ".tar.gz")) (sha256 (base32 "0475w514b7i3gxk6khy8pfj2gx9l7lv2pwacmq92zn1abv01a84g")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'configure) (delete 'check)))) ; no test suite (inputs (list ncurses)) (synopsis "Tiling window management for the console") (description "dvtm brings the concept of tiling window management, popularized by X11-window managers like dwm, to the console. As a console window manager it tries to make it easy to work with multiple console based programs.") (home-page "https://www.brain-dump.org/projects/dvtm/") ;; "dvtm reuses some code of dwm and is released under the same MIT/X11 ;; license. The terminal emulation part is licensed under the ISC license." ;; source: http://www.brain-dump.org/projects/dvtm/#license (license (list expat isc)))) fd8fd952ab8cdb7c2738'>packages/sequoia.scm
AgeCommit message (Expand)Author
2024-07-22gnu: sequoia-sq: Skip a test....Efraim Flashner
2024-07-19gnu: sequoia-sq: Update to 0.34.0....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-keystore-0.2....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-keystore-backend-0.2....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-keystore-softkeys-0.2....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-net-0.28....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-ipc-0.33....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-wot-0.11....Efraim Flashner
2024-07-19gnu: Add rust-sequoia-cert-store-0.5....Efraim Flashner
2024-07-19gnu: rust-sequoia-autocrypt-0.25: Update to 0.25.1....Efraim Flashner
2024-07-19gnu: Add rust-openpgp-cert-d-0.3....Efraim Flashner
2024-07-19gnu: rust-sequoia-openpgp-1: Update to 1.19.0....Efraim Flashner