;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2015 Paul van der Walt ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages djvu) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public djvulibre (package (name "djvulibre") (version "3.5.27") (source (origin (method url-fetch) (uri (string-append "mirror://sourceforge/djvu/DjVuLibre/" version "/djvulibre-" version ".tar.gz")) (sha256 (base32 "0psh3zl9dj4n4r3lx25390nx34xz0bg0ql48zdskhq354ljni5p6")))) (build-system gnu-build-system) (arguments `(#:phases (modify-phases %standard-phases (add-after 'unpack 'reproducible (lambda _ ;; Ensure there are no timestamps in .svgz files. (substitute* "desktopfiles/Makefile.in" (("gzip") "gzip -n")) #t))))) (home-page "http://djvu.sourceforge.net/") (synopsis "Implementation of DjVu, the document format") (description "DjVuLibre is an implementation of DjVu, including viewers, browser plugins, decoders, simple encoders, and utilities.") (license license:gpl2+))) /guix/log/?id=55f7cd701cb6489d8c5f1b5022e6a5bf044f0361'>root/tests/syscalls.scm
AgeCommit message (Expand)Author
2021-02-25syscalls: Add 'mounts' and the <mount> record type....Ludovic Courtès
2020-06-28tests: Do not fail when network interface aliases are present....Marius Bakke
2020-06-05tests: syscall: Support file-systems without extended attributes....Mathieu Othacehe
2020-06-02tests: Allow passing on systems without support for swap devices....Simon South
2020-05-14syscalls: Add 'getxattr'....Jan (janneke) Nieuwenhuizen
2020-02-11syscalls: Re-enable 'pivot-root' test....Ludovic Courtès
2019-10-05syscalls: Add 'add-to-entropy-count'....Ludovic Courtès
2019-06-27syscalls: Add 'terminal-rows'....Ludovic Courtès
2018-07-03syscalls: Define AT_SYMLINK_NOFOLLOW et al....Ludovic Courtès
2018-04-08tests: Skip 'pivot-root' test on Ubuntu's 4.4 kernels....Ludovic Courtès