;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2017 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages digest) #:use-module ((guix licenses) #:prefix license:) #:use-module (guix packages) #:use-module (guix git-download) #:use-module (guix build-system gnu)) (define-public xxhash (package (name "xxhash") (version "0.6.5") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/Cyan4973/xxHash") (commit (string-append "v" version)))) (file-name (git-file-name name version)) (sha256 (base32 "137hifc3f3cb4ib64rd6y83arc9hmbyncgrij2v8m94mx66g2aks")))) (build-system gnu-build-system) (arguments `(#:make-flags (list "CC=gcc" "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC (string-append "prefix=" (assoc-ref %outputs "out"))) #:test-target "test" ;; Parallel testing tries to run ‘xxhsum’ before it's been built. #:parallel-tests? #f #:phases (modify-phases %standard-phases (delete 'configure)))) ; no configure script (home-page "https://cyan4973.github.io/xxHash/") (synopsis "Extremely fast hash algorithm") (description "xxHash is an extremely fast non-cryptographic hash algorithm. It works at speeds close to RAM limits, and comes in both 32- and 64-bit flavours. The code is highly portable, and hashes of the same length are identical on all platforms (both big and little endian).") (license (list license:bsd-2 ; xxhash library (xxhash.[ch]) license:gpl2+)))) ; xxhsum.c scm
AgeCommit message (Expand)Author
2019-10-30gnu: gpxsee: Update to 7.16....Tobias Geerinckx-Rice
2019-10-01Merge branch 'master' into core-updatesLudovic Courtès
2019-09-28gnu: gpxsee: Update to 7.12....Tobias Geerinckx-Rice
2019-09-06Merge branch 'master' into core-updatesMark H Weaver
2019-09-05gnu: gama: Update to 2.07....Efraim Flashner
2019-07-31gnu: gpsbabel: Remove GCC 5 workaround....Marius Bakke
2019-07-08gnu: gama: Update to 2.06....Efraim Flashner
2019-06-13gnu: gpxsee: Fetch from Git instead of a generated tarball....Ludovic Courtès
2019-06-13gnu: gpxsee: Upgrade to 7.8...Nikolay Korotkiy
2019-05-13gnu: gpscorrelate: Update home page....Marius Bakke
2019-02-11gnu: gama: Update to 2.03....Kei Kebreau