;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Sree Harsha Totakura ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages dc) #:use-module (gnu packages) #:use-module (gnu packages compression) #:use-module (gnu packages glib) #:use-module (gnu packages ncurses) #:use-module (gnu packages pkg-config) #:use-module (gnu packages sqlite) #:use-module (gnu packages tls) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module ((guix licenses) #:prefix license:)) (define-public ncdc (package (name "ncdc") (version "1.22.1") (source (origin (method url-fetch) (uri (string-append "http://dev.yorhel.nl/download/ncdc-" version ".tar.gz")) (sha256 (base32 "1bdgqd07f026qk6vpbxqsin536znd33931m3b4z44prlm9wd6pyi")))) (build-system gnu-build-system) (inputs `(("bzip2" ,bzip2) ("glib" ,glib) ("gnutls" ,gnutls) ("ncurses" ,ncurses) ("sqlite" ,sqlite) ("zlib" ,zlib))) (native-inputs `(("pkg-config" ,pkg-config))) (home-page "https://dev.yorhel.nl/ncdc") (synopsis "Lightweight direct connect client with a friendly ncurses interface") (description "Ncdc is a client for the Direct Connect peer-to-peer protocol implemented using ncurses. It is known for its smaller footprint and ease of use.") (license license:x11))) f533d2dac5356&showmsg=1'>README
ad2e515c0dae02127e5a76496463898be6b6'>build-systems/gnu: Allow unpacking/repacking more kind of files....
AgeCommit message (Collapse)Author
2021-05-20The #guix channel is hosted by Libera Chat.Tobias Geerinckx-Rice
* README (Contact): Update network name. * ROADMAP: Likewise. * doc/contributing.texi (Contributing): Likewise. * doc/guix.texi (After System Installation): Likewise.
2020-10-23doc: Update README.Maxim Cournoyer
* README (Installation): Do not mention installing Guix from Git anymore. (Building from Git): Add section.
2020-10-22README: Refer to the manual for building from Git.Maxim Cournoyer
* README (Installing Guix from Guix): Remove section. (Installation): For installing from Git, refer to the "Building from Git" section of the manual and suggest using './pre-inst-env guix pull' rather than 'make install' for installing Guix.
Maxim Cournoyer
2019-06-14tests: Remove expensive and pointless test....Ludovic Courtès
2018-09-22bootstrap: %bootstrap-inputs: Wrap input lists into thunks....Jan Nieuwenhuizen
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2016-04-03build: Add a Guile custom test driver using SRFI-64....Mathieu Lirzin